Jump to content

onlyinajeep726

Members
  • Content Count

    2000
  • Joined

  • Last visited

Everything posted by onlyinajeep726

  1. Thanks Pete!! Glad to be back around!! I can and will once I get all my photos, videos, etc. gathered into one place and back track a little lol. Just curious, who are you on the OM617 Swaps page? To answer your question, I'm at about $4k ± a hundred. Isn't cheap, but it is fun. Biggest two expenses, after getting the stock engine up and running, was the upgraded injection pump and the turbo. I bought a Dieselmeken 7.5mm pump from Göran in Sweden (~$1100 USD) and a gently used genuine Holset Hx30W (~$450).
  2. Here's the one's that damn near match the factory ones perfectly. http://www.euramtec.com/parts/c/c01/7180.html
  3. Boy has it been a long time since an update here or what?! The advent of Facebook has taken its toll on forums and unfortunately, I've been an unsuspecting victim for too long, so without further ado, I give you fine folks of CC a much needed update. The truck has seen a lot of change in the last year. It started with the rabbit hole of YouTube, and the next thing I know, I'm out searching CL for a Mercedes engine. Not just any Mercedes engine, though, but the infamous 5-cylinder OM617 Turbo Diesel! I found one that a guy was pulling from a wrecked 1983 300D W123 Sedan, and got it for
  4. I run a Spartan rear locker on my XJ. 4.10 C8.25. Has great road manners. Sharp turns, and you'll hear it clicking (which is normal). I run 75W-140 gear oil to help quiet it down some.
  5. Anybody else having this issue? I'm not getting any notifications when I log onto CC. It's always empty. I've looked through my notification settings, but I don't see an option for it. I don't want to be bombarded with emails, so I prefer to only see notifications when I visit the site.
  6. And this one: https://www.facebook.com/groups/279185167172/
  7. One issue I've noticed is that I'm not getting notifications when someone replies to a thread I follow or have posted on... Is that something others have experienced thus far?
  8. Yea, I did what Ωhm did and just popped the factory connector out to rotate it 180°.
  9. onlyinajeep726

    onlyinajeep726

    1986 Comanche
  10. I'll stay tuned for the "update". Fingers crossed it works. :crossfingers:
  11. I'd like to start off by saying, that despite the fact I haven't really been as active here as I once used to be, I still admire this forum, and its mission, greatly. That being said, as I've come here lately (and other forums), the whole PhotoBucket debacle has really killed off a lot of great threads. It's really true what they say: A picture is worth a thousand words. It's quite disgusting of a business to randomly, and with little to no warning, decide to make a huge overhaul that negatively impacts their users. Forums, for me especially, have been a huge contributor to my learning abo
  12. Did you ever dig this thing up?
  13. This what you talking about? http://comancheclub.com/topic/40239-buried-treasure-maybe/
  14. I've done it before on XJ housings by way of prying... Lots of patience and carefully. Done one pair, no issues. The other pair, cracked and chipped several places. My friend did split a set using a heat gun and prying. Looked like crap because parts were melted, and other parts cracked. Why do you want to split them, anyway? Custom LED boards or something?
  15. Spartan in the rear, Selectable or a Eaton/Volvo G80 up front, IMO, is the best bang for the buck on an occasional wheeling rig. What are you going to regear to, by the way? It's my understanding that 3.55 would be perfect for a 4.0/5-speed/32" tires. (Also easiest axle and ratio to find at the junk yard to swap in, and way cheaper to go that route versus paying for a regear) I have 4.10's in my MJ, same engine/trans/tire combo, and they're a bit too deep. I should've stayed at 3.55 since I already had those in the truck.
×
×
  • Create New...