Jump to content

I'm a Poppa!!!


Recommended Posts

3529563897_f7ae890d5c.jpg

 

1988 MJ Pioneer. 167,xxx miles, 2WD, I6, AW4, D30/35, $900.

Alright, so she's a little ugly.

The clear coat has faded/is fading.

The bed is all scratched up (it will be getting Rhino Lined).

There is no tailgate (I'm looking for one).

The rear bumper is bent up.

Minimal rust on the body -- mainly in spots where the paint has been scratched off.

No discernible rust on the frame/underbody.

Temp gauge doesn't read proper temperature.

I think it's low on antifreeze. There is none in the overflow bottle (closed system). Heat blows HOT, though.

AC does not work ... maybe the system needs a recharge. How do you know if it needs a recharge, or if the compressor is shot?

Idles high in 'Park'.

Crazy oil leak(s) -- the whole underbody is coated in oil; of course it drips on the exhaust too, so it smokes.

Shifts nicely, and the engine is powerful.

Possible missing vacuum hoses.

I also don't think the front turn signals work, but the rear do.

When the headlights are turned on, the clock goes away but the right signal indicator in the dash stays lit.

Grounds and battery terminals need to be cleaned.

The speakers in it are so massively sucky.

Sliding rear window with no handle.

No headliner/dome light.

Courtesy lights in the 'B' pillar don't light up.

Is wired for trailer lights and has 2" ball. What's the towing capacity of an MJ?

 

I think that's it for now.

Link to comment
Share on other sites

Whats the gameplan?
looks like its in decent shape what are your plans for it.

 

 

The goal is for this to be a very solid DD. I'd like to turn this thing into nice shape. New paint and such. Make it a nice Mall Crawler! I think my first plan of action is to get it detailed, inside and out. Then, get the major stuff fixed, and slowly work on the minor (unimportant) things as well.

 

My first four goals are:

Fix the A/C,

Figure out why the front turns don't work,

Try to find and stop the oil leak,

Figure out why the temp gauge is reading so low.

 

After those three:

Rear bumper+tailgate,

Speakers,

Cosmetic touch-ups.

 

Long term:

New paint,

New tires,

New seats.

Link to comment
Share on other sites

Questions should go in the Tech forum so more people will see them. The projects forums is mostly for updates from you as the project progresses. :thumbsup:

 

Right on, I'll start a never-ending thread of questions. :eek:

Link to comment
Share on other sites

Questions should go in the Tech forum so more people will see them. The projects forums is mostly for updates from you as the project progresses. :thumbsup:

 

Right on, I'll start a never-ending thread of questions. :eek:

Welcome to the club! Nice looking MJ :thumbsup: . Post away with the questions! That is what the ComancheClub and the Tech section is here for :cheers:

Link to comment
Share on other sites

Questions should go in the Tech forum so more people will see them. The projects forums is mostly for updates from you as the project progresses. :thumbsup:

 

Right on, I'll start a never-ending thread of questions. :eek:

Welcome to the club! Nice looking MJ :thumbsup: . Post away with the questions! That is what the ComancheClub and the Tech section is here for :cheers:

 

Thanks; I've already started with the questions.

Link to comment
Share on other sites

No new pics but I did get the AC working again. The PO unplugged some of the wires running from the compressor to wherever they go. I plugged them back in and we're in business. I'm thinking of getting the system recharged anyways. Does refrigerant go bad?

 

I also used the last half can of degreaser on the truck. Boy, this thing is NASTY. I found the source of one of the major oil leaks too; the crimp between the soft and hard hoses for the trans fluid return from the trans to the rad. I'll be replacing that with hose clamps like I did on my XJ.

 

I'll be plugging up some of those vacuum hoses, too, and replacing the broken ones.

Link to comment
Share on other sites

  • 2 weeks later...

Update:

I finally fixed the leaking trans line, so now trans fluid doesn't spray everywhere. I'll need to attempt the rear main at some point along with the oil filter adapter o-rings.

 

The A/C works now, though the drain tube is all blocked up and it drains into the cab. I couldn't find the drain hose, so I'll hafta look for it again. My XJ does this too.

 

I unblocked the CCV grommet, so no more oil mist coming out of the intake tube for the valve cover. I also ordered a new one.

 

I got the interior detailed, so now it doesn't smell anymore.

 

New door speakers.

 

Got new rims. Just like THESE. However, it wasn't as easy as getting them mounted.

 

The two rear tires are 215/75 and the two front were 215/60. Went to Sam's and got (2) 215/70 to replace the /60's. Turns out that the /75's are over 10 years old, so they wouldn't remount the tires on the new rims. So, I have the /70's mounted on the new rims on the front, and I hafta go get some tires for the rear and get them mounted.

 

I also had an idea for in-cab lighting. The two b-pillar lights don't work so there's no light on the inside. My MJ also doesn't have the headliner. This leaves a pretty sizable gap between the top of the cab and the lip that the head liner mounts to. I was thinking of getting some low-key LED strips and running them all around the top of the cab (hidden in the lip) and they'd come on when the door opens. Low power consumption, but different. Ideas, thoughts?

Link to comment
Share on other sites

  • 3 weeks later...

The radiator recently went south on me on my way home from work. Not exactly sure what happened, but have a leak that lets out coolant AND trans fluid. I'm thinking it's possible there's an internal leak, too, and the red in the coolant came from the trans fluid.

 

The poop thing is, I JUST replaced all the hoses and t-stat. I'm going tomorrow to pick up a known working (used) radiator and get it installed and get the MJ running again since it's my DD.

 

I also need to do the rear main at some point in life, it leaks something wicked.

Link to comment
Share on other sites

  • 4 weeks later...

Yeah, I haven't found very much rust at all, just a few minor spots on the body.

 

The brake MC was bad, so swapped it out with a booster and MC from a 99. The push rod is hella long, so the pedal is freaking high. I will get the rod swapped out later.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...