Jump to content

Put battery in backwards...fixed!


Recommended Posts

in my haste to get my project truck put back together last weekend i managed to put the damn battery in backwards for a few seconds...

simply the dumbest thing i have done in a while. now i have an intermittent no crank/start issue.

 

i am sure i screwed the pooch in more than one way with this idiotic mistake can you guys tell me all the stuff I'm going to have to repair/replace to get this fixed?

 

i have gotten it running for a few minutes but like i said sometimes it won't respond to the key at all.

 

any suggestions?

 

 

Link to comment
Share on other sites

did work on this problem today:

 

  • replaced ignition switch(note to others:tilt column and non-tilt use a different part)
  • upgraded grounds as recommended in cruisers renix tips
  • replaced battery terminals
  • bought new battery(waiting to solve this before putting it in)
  • swapped out starter relay with a new looking one from jy
  • checked fuses, none blown

so the issue is not completely fixed yet

here's where i stand

 

key in on position gets the accessory circuit going(radio, air etc)

key in start position cuts off accessory circuit but fails to crank(which is why i swapped the relay)

tried starting by providing 12v to the sol wire on the relay, and it cranked without starting

put some gas in it since it wouldnt start and it had to be low after having th fuel leak and not being filled since i can't even remember

jumped the sol wire again and it fires up and runs good

 

I'm thinking the relay may still be bad...but I'm not getting any voltage from the ign wire that goes to the relay when i turn they key and i certainly don't get any voltage out of the green sol wire or terminal on the relay

could i have a bad ignition switch from the store?? 

i mean it seems to work as far as the accessory circuit goes and i made sure to line up the sliding hole part to how the old one was when i swapped them.

 

i should have tried giving 12v to the ign terminal on the relay and seeing if the sol wire went hot, that would have ruled out the relay. I'm already cleaned up now though, maybe tomorrow.

 

any thoughts?

Link to comment
Share on other sites

I know on mine (2.5) there is a breaker and at least one fused link.

 

I'd check the wiring off the battery and the alt with a test light to make sure there is power supplied to the relays.

 

I know you say it runs when you jump the starter, power is getting to the fuel pump and ignition.........I'd still check though.

Link to comment
Share on other sites

Stand to the side of the truck and have someone crank the engine while you hold your finger on the starter relay.

If it clicks the problem is not in the ignition switch.

 

The starter on my 88 Model Comanche 4.OL Renix  sometimes won't respond to the ignition switch.

It's not the switch, relay or wiring causing the problem, it's simply that the starter solenoid is bad and doesn't pull the electrical contacts together in the solenoid. .

If I bump it with a piece of wood it starts.

 

Look at everything.

 

hope this helps

steve

Link to comment
Share on other sites

okay guys. So I checked the fusable links but they all seem to check out. Hoe many are there exactly? I mean I checked all the ones I could find but maybe I'm missing one. Going to take some time today to mess with it and maybe drop by the jy and grab an ecu and maybe even a fuse box.

Link to comment
Share on other sites

So i went to the JY and got an ECU and swapped it in.

No change.

I also picked up another ignition switch from the same truck. It had recently been replaced so I got another good as new part for $2.50

 

To test the starter relay I went ahead and provided 12v directly to the ign terminal on the relay and with the key in the ON position it started right up.

 

 

Before I Change the ignition switch again, Does anyone know if there is something between the ignition switch and the starter relay I should check?

Link to comment
Share on other sites

I went ahead and swapped out the starter switch again and made sure to test it each step of the way.

I think I had it sitting a little too far back on the column, but now it works!

I through some gas in the old guy and took him for a spin.

 

A few things I noticed:

 

Tach not working

Volt gauge not working still

Cut off twice, once while I was backing up and once while I was on a good incline.

I havent put the new battery in so i think it may be something to do with the battery or cables (which I havent replaced yet either)

The reason I think that is because my radio presets went away after the cut offs.

 

Other than that though it starts up even better than before this whole thing happened and runs good!

 

 

 

Thanks for everyone's help!

Any ideas on the remaining issues greatly appreciated!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...