Jump to content

Comanche won't run after 91+ upgrade


Recommended Posts

Here's what I have:

'88 Comanche 2.5L with:

'93 harmonic balancer, A/C Compressor, Power Steering Pump, Alternator, Distributor & sensor, engine wiring harness & computer, chassis harness, fuel pump & sending unit, intake manifold, fuel rail, injectors, etc. etc.

'93 4.0 throttle body

91+ 4.0 62mm tb spacer (I know people say it is faster with a smaller bore, I plan on playing with this once it is running by testing it with and without the spacer).

 

When I try to start it, it just won't run. If I hold the throttle wide open, it might stay running for a few seconds, but still doesn't sound right and will die immediately after letting off the throttle. It won't even do that all the time with wide open throttle, sometimes it won't catch at all. I think I read somewhere that if the sensor at the back of the engine/front of the transmission bellhousing is bad it wouldn't run. Any other ideas? I pulled the boot off each spark plug and checked to make sure they were sparking, which they are. The plugs are new, but are the ones spec'd for the '88 engine if that makes a difference. The cap & rotor are new, and spec'd for the '93 distributor I put on it. It has fuel pressure at the fuel rail. Even if an injector was clogged, I think it would take at least 2 clogged injectors to make it not run, not sure. All the stuff I've thrown on is from the junkyard, so it is all suspect.

Link to comment
Share on other sites

Did I miss something? I didn't see any mention of replacing the '88 CPS (that's the sensor in the bell housing) with a 91+ CPS. Or the flywheel.

 

You have a problem. The '87 thru '90 flywheel and CPS operate on a completely different principal than the '91 and newer. The Chrysler ignition/injection system can't read and interpret the signal from the older CPS. And you can't just replace the CPS, because the 91+ uses a different tooth pattern on the flywheel (or flex plate) to trigger the CPS.

Link to comment
Share on other sites

Did I miss something? I didn't see any mention of replacing the '88 CPS (that's the sensor in the bell housing) with a 91+ CPS. Or the flywheel.

 

You have a problem. The '87 thru '90 flywheel and CPS operate on a completely different principal than the '91 and newer. The Chrysler ignition/injection system can't read and interpret the signal from the older CPS. And you can't just replace the CPS, because the 91+ uses a different tooth pattern on the flywheel (or flex plate) to trigger the CPS.

 

 

Nice catch jamminz.gif

Link to comment
Share on other sites

Did I miss something? I didn't see any mention of replacing the '88 CPS (that's the sensor in the bell housing) with a 91+ CPS. Or the flywheel.

 

You have a problem. The '87 thru '90 flywheel and CPS operate on a completely different principal than the '91 and newer. The Chrysler ignition/injection system can't read and interpret the signal from the older CPS. And you can't just replace the CPS, because the 91+ uses a different tooth pattern on the flywheel (or flex plate) to trigger the CPS.

 

 

Nice catch jamminz.gif

Yep...don't think I would have thought of that one...not right off anyway. I was thinking that the distributor was off by a tooth or two.
Link to comment
Share on other sites

Plugs are gapped, and yes, I have replaced the injectors as well (the TBI injection just has one on top of the throttle body whereas the MPI has one in the intake manifold right next to the head for each intake port, total 4).

 

I haven't pulled the plugs and smelled them to see if gas is getting to them, but it is getting to the fuel rail and at least 2 of them would have to be clogged to cause this.

 

I swapped in a '93 distributor and all the other sensors along with the wiring harness & ECU, manifold as well. I don't believe the distributor can be indexed, it just fits in one way and relies on the sensor there anyways. Correct me if I'm wrong.

 

I did replace the CPS with a 91+ CPS, but this is the first I've heard that the flywheel is different. So I guess the flywheel is next on the list huh? Anything along with it that I need to replace?

Link to comment
Share on other sites

It wouldn't be necessary for making the engine run, but the 2.5L has a 1-piece rear main seal, which means you have to pull the tranny and flywheel to replace it. If you're pulling the tranny to replace the flywheel, it would probably be a good idea to pull a preemptive strike and do the seal while you have access to it.

Link to comment
Share on other sites

Forgive my ignorance here, but I just can't see removing and reinstalling the old 4 speed manual. I'd rather do an AW-4 or even better an NV3550 (I'm aware of what it takes to convert the bellhousing & stuff). The flywheel is attached to the engine, not the transmission, correct? Does the flywheel part # depend on which transmission I have in it? Will a '93 flywheel bolt up no problem to the '88 engine?

Link to comment
Share on other sites

I just went to autozone and ordered one for a '93 Cherokee 2wd 2.5L manual. $60. It'll be in Friday. Does it just depend on whether it's stick or auto, or specifically on transmission model (ax-4 or ax-5 vs. ax-15 or nv3550)?

Link to comment
Share on other sites

  • 2 weeks later...

New '93 2.5L flywheel is on and it still won't start. With the old flywheel it sounded like it was close but like the timing was off. Now it doesn't even sound like it's close to starting, it just cranks & cranks. I'll have to re-check all the connections again another night. Anybody have any other ideas? Feel free to ask questions.

 

Thanks

Link to comment
Share on other sites

Forgive my ignorance here, but I just can't see removing and reinstalling the old 4 speed manual. I'd rather do an AW-4 or even better an NV3550 (I'm aware of what it takes to convert the bellhousing & stuff). The flywheel is attached to the engine, not the transmission, correct? Does the flywheel part # depend on which transmission I have in it? Will a '93 flywheel bolt up no problem to the '88 engine?

 

...Why?

 

AW-4 is a lot more trouble, and only worth it if you really, really want to have an automatic. NV3550 is gonna be a lot of fabbing and part hunting. There's nothing wrong with the 4 speed. Having a 5th gear is useless if your motor doesn't have the power to turn it, which the 2.5 doesn't really have unless you have 4.10.

Link to comment
Share on other sites

5-speed will allow me to regear for better use of the powerband. It'll be geared lower around town but still have the higher gear for the highway. I did put the 4-speed back in for now though, only because this is turning into a never-ending project.

Link to comment
Share on other sites

5-speed will allow me to regear for better use of the powerband. It'll be geared lower around town but still have the higher gear for the highway. I did put the 4-speed back in for now though, only because this is turning into a never-ending project.

 

M'kay, I was basing that off of you keeping the 3.55

Link to comment
Share on other sites

Well, mine would not start becasue I did not have the cable from the battery to grounding post attached to the side of the engine. You might want to check your grounds. Yes, I saw that you had checked for spark and had it, but mine had spark at the plugs as well but still would not start - just cranked.

 

And yes I saw you had fuel at the rail, but it may be partially cloged somewhere along the line or might have become clogged while you were trying to start it. Check the pressure at the fuel rail which should be around ~ 40 lb at crank and 32 ~ 35 when running.

 

Pull the last plug in the firing order and see if its fuel fouled.

Link to comment
Share on other sites

No need for a scanner. Short the diagnostic terminal to ground and count the check engine light flashes. If you didn't hook up a light, use a test light between ground and serial out terminal.

 

But then again, an OBD-I scanner only costs $15 to $25.

Link to comment
Share on other sites

Last time I saw them was at Autozone. The cheap ones just display the codes, nothing more. The obscenely expensive ones interface with the computer and can tell you every bit of data the computer has. On some vehicles they can also spoof sensor data and change the computer operating mode in real time.

 

The cheap readers that just display the codes are usually useless since you can get the same info by counting the flashes of the check engine light. But if he swapped in an OBD I engine/control system and didn't hook up a light, it might be useful.

Link to comment
Share on other sites

Last time I saw them was at Autozone. The cheap ones just display the codes, nothing more. The obscenely expensive ones interface with the computer and can tell you every bit of data the computer has. On some vehicles they can also spoof sensor data and change the computer operating mode in real time.

 

The cheap readers that just display the codes are usually useless since you can get the same info by counting the flashes of the check engine light. But if he swapped in an OBD I engine/control system and didn't hook up a light, it might be useful.

That still sounds like you're describing OBD-II scanners. I bought mine at Auto Zone, for $79. It's OBD-II only. OBD (or "OBD-I") was a "non-standard standard," meaning each manufacturer had their own codes and their own connector. I'd love to find an affordanble "OBD-I" scanner that'll fir the Jeep connector but I don't think it exists.

Link to comment
Share on other sites

No, I mean OBD-I. The meaning of the codes is different between brands, and therefore most scanners are brand specific.

 

OBD-II is truly a standard, and one scanner works for all.

 

If you want to find one that fits the Jeep connector, I imagine you mean 91 through 95? The Renix ones don't have even OBD-I. But I don't remember having seen one. I know I've seen Ford (and Ford brands), as well as GM including Cadillac (which is different from the other GM ones). Maybe the Jeep ones are the same as Chrysler?

Link to comment
Share on other sites

Yes, I'm asking about an "OBD-I" scanner for the 91 thru 95 Jeep. I know the Renix doesn't store codes and you need a $3,000+ Snap-On scanner to read those. I thought you were saying that you know Auto Zone carries an affordable OBD scanner for Jeep, but now it sounds like you're saying they don't.

 

A few posts above, you wrote:

But then again, an OBD-I scanner only costs $15 to $25.
Link to comment
Share on other sites

I never looked for a Jeep one or at Jeep stuff before, because I never had a Jeep before. I'm not saying they don't have one. I'm saying they used to have Ford and GM, so they *may* have Jeep/Chrysler ones as well, which I *assumed* they did.

 

Sorry if I unintentionally implied something else with my earlier post.

 

And I know, assumption is the mother of all f..k ups. I should have known better :oops:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...