Jump to content

Looky what I found:


Sir Sam
 Share

Recommended Posts

2006 Liberty limited, perfect, not a bit of body damage, all the limited goodies, 80k miles.

 

Turns out it had been confiscated by the state for drugs, then sold at auction after the title had been destroyed by the state. Basically it was never going to get a title again, the owner of the yard said he drove it for awhile with dealer tags and then they put it out there.

 

Seems silly, the state just shot themselves in the foot by destroying the title, it could have easily have sold for much more with the title, and not wound up in the junkyard. The person who lost their car still gets punished, and we the people are a little better off with some more money from confiscated vehicle sales.

 

Whatever!

 

jykj1.jpg

jykj2.jpg

jykj3.jpg

jykj4.jpg

jykj5.jpg

jykj6.jpg

jykj7.jpg

jykj8.jpg

http://colorado4wheel.com/images/misc/jykj9.jpg

http://colorado4wheel.com/images/misc/jykj10.jpg

 

So all told I pulled about $800 worth of stuff, got plenty of stuff to sell and ship. Got the heated leather seats, overhead console, drivers door, grill(chrome), tails, 4 wheels, power outside and power inside mirrors, fogs, 6 disc CD changer, limited silver radio bezel and shifter bezel, infinity front speaker.

Link to comment
Share on other sites

My girlfriend has a 2004 Liberty. I would be swapping parts like no tomorrow. The amber lights in the front bumper, the flares, the brushed aluminum bezels, the grill, even the center console is completely different, that one is way better.

 

The 04 has a different bumper/grill/fenders/turn signals/foglight/header panel/flares, fairly involved swap.

Link to comment
Share on other sites

rear speed sensors?

:brows:

 

You too huh..... ABS light on the CRD

 

 

yup. :shake: could still be the wire running to it, but slapping another sensor would be a quick check. if any junkyard around here had a KJ with rear disks. :fs1:

 

Crap, wish I had thought of that, I've been putting off dealing with it because the airbag light didn't really bother me that much.

 

Oh well, one of these days.

Link to comment
Share on other sites

rear speed sensors?

:brows:

 

You too huh..... ABS light on the CRD

 

 

yup. :shake: could still be the wire running to it, but slapping another sensor would be a quick check. if any junkyard around here had a KJ with rear disks. :fs1:

 

Crap, wish I had thought of that, I've been putting off dealing with it because the airbag light didn't really bother me that much.

 

Oh well, one of these days.

When you figure it out being wiring or sensor let me know.. I hate the ding then seeing the dash light up... blah....

Link to comment
Share on other sites

rear speed sensors?

:brows:

 

You too huh..... ABS light on the CRD

 

 

yup. :shake: could still be the wire running to it, but slapping another sensor would be a quick check. if any junkyard around here had a KJ with rear disks. :fs1:

 

Crap, wish I had thought of that, I've been putting off dealing with it because the airbag light didn't really bother me that much.

 

Oh well, one of these days.

When you figure it out being wiring or sensor let me know.. I hate the ding then seeing the dash light up... blah....

 

Ya I haven't looked into it yet, I got spare parts in the parts CRD outback. I did notice that one time it worked correctly for a little while driving around in the rain.......maybe coincidence or not.

Link to comment
Share on other sites

mine was on and off, hit or miss for a while, then it died for good.

 

I'm trying to collect the whole set of lights. :yes: we've had the check engine light on ever since I unplugged that one sensor. the ABS, stability, and trac control since the wheel sensor issue, the tire pressure light since one of the pressure sensors died. and now the part time light is on even though it's in 2wd. :shake:

Link to comment
Share on other sites

mine was on and off, hit or miss for a while, then it died for good.

 

I'm trying to collect the whole set of lights. :yes: we've had the check engine light on ever since I unplugged that one sensor. the ABS, stability, and trac control since the wheel sensor issue, the tire pressure light since one of the pressure sensors died. and now the part time light is on even though it's in 2wd. :shake:

 

 

You know that black electrician's tape? It works great for fixing problems like that.

Link to comment
Share on other sites

lord only knows. my parents are going back to georgia soon and the Jeep goes with them. again. :( chances are real good you'll be doing the belt change first. changing anything else at the time? (pump, pullys etc)

 

If you could send a sensor, that'd be awesome. :bowdown: although I'm assuming they are the same sensor at each wheel?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...