Jump to content

Sway Bar Links

Recommended Posts

I am in the process of replacing my sway bar. I was able to successfully unbolt it from the frame. As I unbolted the sway bar ends from the sway bar links, I snapped one of the links off. So I thought now would be a great time to replace those too.


I am trying to unbolt the vertical sway bar links from the front axle. IT APPEARS there is a nut and star bolt holding them on. I can take the bolt off but the sway bar link will not loosen and the star bolt will not turn, EVEN WITH THE NUT OFF. :wall: I fear I am stripping the guts out of the star bolt. I have PB blasted it all week and put a torch on it for about a minute. It will still not turn. Is that bolt theated in that hole? I have tried tapping it with a hammer too. It acts like it is welded on.


I am trying to keep my composure but my head is getting sore from repeatably ramming my forehead into my bumper from frustration.


Any help would be appreciated.

Link to comment
Share on other sites

The star is an inverted torx you are supposed to use to keep the stud from spinning. The stud is kinda of a pain in the butt if its not still attached to the truck or the swaybar. If you already broke one, I would say a sawzall or a torch is in order.


A torch and some patience will be your best friend if you are trying to save the other link. Otherwise, pry pull, heat, bend, knaw and chew to get the other one off.


Rob L. :cheers:

Link to comment
Share on other sites

i'm confused as to why everyone is trying to turn and remove the torx bolt. you take the nut off, and slide the link off the torx bolt, and slide the new one on :dunno:


Very valid question. I wanted to remove them because I didnt think I would be able to get new links slid over those spacers in the bolts. Those links were very tight even though the bolt was removed. There was no way I was getting new ones on without replacing those rusty bolts too.

Link to comment
Share on other sites

i just used the BFH a few times pluse heat plus a full can of WD40 which did nothing...


WD - 40 is not penetrating. It's a lubricant. You need to use Penetrating Blaster.

:rotfl2: everytime someones gotta say it :yes: :rotfl2: :rotfl2: :rotfl2: :rotfl2:


Because its true?


Rob L. :hmm:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...