Jump to content

Big Dan

Members
  • Posts

    337
  • Joined

  • Last visited

Profile Information

  • Location
    Bloomfield, KY

Recent Profile Visitors

1178 profile views

Big Dan's Achievements

Comanche Aficionado

Comanche Aficionado (4/10)

  1. No. All XJ seats will require modding, as the MJ floor bracket is different. However, up to 94 (maybe 95) is much less work. Sent from my Pixel 4 XL using Tapatalk
  2. An ax5 will not bolt to the 4.0. The 2.5 and 4.0 are a different bolt pattern. If I'm correct, the ax5 is a Chevy bolt pattern. Fix is ax15
  3. Yes Sent from my Pixel 4 XL using Tapatalk
  4. I don't know if the Ranger leaf springs are the same dimensions. You know, for sure, that the MJ suspension components with line up with the mounts. You'll, obviously, have to weld perches in the correct place. Sent from my Pixel 4 XL using Tapatalk
  5. But is there an ac delete bracket in its place? Or, do you have a shorter belt and skip the ac pulley all together? Sent from my Pixel 4 XL using Tapatalk
  6. For reference, the "outside" part as in the surface where the studs are and not the splines of the hub? Sent from my Pixel 4 XL using Tapatalk
  7. I'm in Sent from my Pixel 4 XL using Tapatalk
  8. Is Myers Machine the shop in Lexington or something closer to you? Sent from my Pixel 4 XL using Tapatalk
  9. Complete shot in the dark, but, it may be the circuit board on the back of the instrument cluster. Sent from my Pixel 4 XL using Tapatalk
  10. I installed this Bosch unit, two years ago, and have had zero issues. FWIW, it was $100 when I got it. $150 now. https://www.summitracing.com/parts/bch-al653n/overview Sent from my Pixel 4 XL using Tapatalk
  11. So, to clear this up for future readers - took the FPR out of my parts jeep and it still didn't work. At that point, I retraced what I did and had the "doh!" moment. Either way, all is good now. As always, thanks for the assistance. Sent from my Pixel 4 XL using Tapatalk
  12. I do. I caught it just now. Thanks for the help. Embarrassment abound.
  13. Replaced some fuel lines today. Upon reconnecting everything, I have a no start condition, with no fuel at the rail. Everything stops at the fuel pressure regulator. If I remove the FPR, and prime the pump, fuel shoots everywhere. Replace the FPR (tested off of the rail and on the rail), I get nothing. Removing the hard line from the FPR results in, again, fuel spewing everywhere. Are there troubleshooting options or is a new one simply needed? If a new one is needed, what is recommended? There just seems to be junk everywhere on Ebay.
  14. I'll take the rear window gasket. Pm me with payment info, please Sent from my Pixel 4 XL using Tapatalk
×
×
  • Create New...