Jump to content

Recommended Posts

The 241OR transfer case bolted right up correct?  Did you get your speedometer to work after swapping in that tcase? Lastly, your rear driveshaft you had to get that flange welded on? 

 

Sorry about all the questions just thinking about getting one for my comanche

Share this post


Link to post
Share on other sites
The 241OR transfer case bolted right up correct?  Did you get your speedometer to work after swapping in that tcase? Lastly, your rear driveshaft you had to get that flange welded on? 
 
Sorry about all the questions just thinking about getting one for my comanche


The speedo does not work due to the 241 having an electric speedo and the older Renix Jeeps having a mechanical one. Rear output on the T case was swapped to a regular yoke that I had Tom woods make me so no drive flange on the case anymore


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

No real updates lately. Been focusing my spare funds on the upcoming holidays. I did manage to order and install this new stinky fab trans mount after my stock one took a beating on my last wheeling trip. Planning some upgrades starting right after the new year though

5bf69190d8c724b333746839c6096df2.jpg

Share this post


Link to post
Share on other sites
2 hours ago, billytoad631 said:

 


The speedo does not work due to the 241 having an electric speedo and the older Renix Jeeps having a mechanical one. Rear output on the T case was swapped to a regular yoke that I had Tom woods make me so no drive flange on the case anymore


Sent from my iPhone using Tapatalk

 

 

What year did you get yours from? A tj rubicon or a jk? you didn't change the front flange?

Share this post


Link to post
Share on other sites
 
What year did you get yours from? A tj rubicon or a jk? you didn't change the front flange?


Should be out of a TJ. The front has a yoke as well. Got it like that so someone along the line changed the flanges for yokes. Probably so stock style shafts can be used


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×