Jump to content

4 way flashers


Recommended Posts

don't you have bigger fish to fry than flashers? :hmm: seems to me like you have a broke down vehicle to worry about ;) but if your signals work somone could have put the wrong flashers in, or if there isnt a ticking when there on it could be wiring or the switch... let us know the exact status on it.

Link to comment
Share on other sites

Keep in mind that the turn signals and hazard flashers in the XJ and MJ do NOT share the same flasher can. There are two flasher modules on the fuse panel. They interchange, so you can swap them one for t'other as a quick test.

 

If the turn signals work and the hazard flashers don't the wiring is good so it must be a fuse or the flasher module. If neither the turns nor the hazards work ... you have deeper-rooted problems.

Link to comment
Share on other sites

don't you have bigger fish to fry than flashers? :hmm: seems to me like you have a broke down vehicle to worry about ;) but if your signals work somone could have put the wrong flashers in, or if there isnt a ticking when there on it could be wiring or the switch... let us know the exact status on it.

Ya your right, but i havwnt had no probs since and i need flashers for inspection thats due.

Yes, my signals all work. Ill try the flasher, thanks

Link to comment
Share on other sites

take one of your tails off and see if your test light flashes when its on four way. make sure youve got a good ground and test it with your blinker first so you know your in the wire well enough, then get somone to turn your flashers on. if the wires getting juice back there you have a problem with your plug, but i doubt thats the problem. i would first off make sure my flashers were there and the right part (call a parts shop and have them look up the part for a 4 way flasher for your mj) and make sure you have the right one in there, because the 4 ways use a different kind of flasher than the blinkers, and if i remember correctly its more expensive so somone might have got cheap and bought two of the same kind. if it does have a flasher in it see if it lights the bulb up before they get to the flasher. if it does then change the flasher and you should be good, if not you need to do the first thing i mentioned. I hope this is helpfull, and if i said anything that makes me look like a douche i don't think your stupid, i jsut didnt want to leave anythign out :thumbsup:

Link to comment
Share on other sites

Did you REPLACE the falsher units? I had this exact thing happen on my bosses MJ, it would slowly flash on one side and not flash at all on the other. Replaced the flasher unit, and theyre fixed. Its the small round aluminum looking can that pushes into the fuse block. There should be two of them, one for turn signals, and one for 4 ways. They both plug in the same, but I think the 4 way is a heavy duty unit so as to make all the lights flash at a reasonable speed. If you replace get new heavy duty flashers for both.

Link to comment
Share on other sites

yeah, I am having a major issue with my lights, the turns to the left only come on to stay on, the running lights come on also. The blinkers to the right blink really really really slow, like "DUH" slow. I took the flasher rig out and cleaned it, made no difference. Could it still be F****ED!?

Mine did the same thing . I had to clean all the grounds and there was a hot trailer plug wire to a ground. After that...waa laa...no more dull right blinker

Link to comment
Share on other sites

yeah, I am having a major issue with my lights, the turns to the left only come on to stay on, the running lights come on also. The blinkers to the right blink really really really slow, like "DUH" slow. I took the flasher rig out and cleaned it, made no difference. Could it still be F****ED!?

Mine did the same thing . I had to clean all the grounds and there was a hot trailer plug wire to a ground. After that...waa laa...no more dull right blinker

 

so your problem is solved sterling?

Link to comment
Share on other sites

yeah, I am having a major issue with my lights, the turns to the left only come on to stay on, the running lights come on also. The blinkers to the right blink really really really slow, like "DUH" slow. I took the flasher rig out and cleaned it, made no difference. Could it still be F****ED!?

Mine did the same thing . I had to clean all the grounds and there was a hot trailer plug wire to a ground. After that...waa laa...no more dull right blinker

 

so your problem is solved sterling?

yes sir

Link to comment
Share on other sites

first thing I heard that makes sense all day!!!

 

hey you boys have any good ideas to clean the terminals in the fuse block itself? Without all the pain the arse of removing it?

 

 

I used steel wool and a small nail. :dunno: probably not the best technique out there. You might want to post that as a new topic so more guys will see it. :thumbsup:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...