Jump to content

Strange dash light problem need help asap


Recommended Posts

Tonight I get in the MJ and turn the lights on and poof the fuse for the dash illumination pops. So I put a new fuse in then the parking lights/ tail light fuse blows! As of right now I have the two fuses in and they aren't blowing, BUT now I have no dash lights and the drivers side brake light doesn't work. I can turn the headlights on and all the parking and tail lights are on as normal but the dash lights are still out as well as the drivers brake light. Any ideas? I forgot to mention the bulb in my clock blew out also so I disconnected the clock thinking it had a short somewhere but still no change.

Link to comment
Share on other sites

It sounds like a short somewhere but that is where the detective in you kicks in. I was lucky with my 89 and found a break in my ground wire from the battery. I spliced it and had no related issues. Start at the battery or at the tail lights and work your way up. Also check for clutch fluid seeping behind the fuse box. Good Luck!

Link to comment
Share on other sites

I have all the lights working properly now. The dash illumination fuse pops when I turn the headlights on and it also pops the exterior lights fuse. So both fuses are popping, if I leave the dash fuse out the lights work no problems. So now these two circuits have to be connected by something for them to both blow. The only thing I can come up with is the headlight switch. Is it possible for the switch to function the lights but not the dimmer? Maybe there is a short in the switch itself causing the illumination lights to not work?? I am lost, confused, and very aggravated. :fs1:

Link to comment
Share on other sites

Thank you hornbrod! I saw that ground but I wasn't 100% sure it was in the dash light circuit. The ground checks out and I added another ground but it still pops the fuse. I am at a loss and the dash is going back together without any lights.

Link to comment
Share on other sites

Ok I am a fool... I tore up half the floor the other day to fix a small rust spot and when I put the seat back in I pinched a wire for the 4x4 indicator light! I spent 9 hours tracing wires trying to find the short when it finally occurred to me to check the floor. :doh:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...