Jump to content

update to MJ idling rough


Recommended Posts

Been trying to fix my rough idle that just happened over night. With no real warning other than a slight, like sputter while driving down the freeway on my 1986 2.5l TBI but its still the same :mad: ive changed the cps, plugs, wires, cap, rotor, fuel filter, dropped tank cleaned it out, tried a Reman injector but seemed to run worse (don't know if this is a problem but parts store gave me one with red around connector not green like mine???) ive tried checking every sensor but I'm not too good with ohm readings (don't understand what setting to put it on) so I'm just frustrated with it all. I checked the fuel pressure and it reads 17psi and manual says it should be at the most 15psi. Would 2 pounds make that big of a difference? i tried getting to the pressure regulator but its in such a weird spot and i think it has a plug. Anyone have an easy way to get to it and adjust? Should i just start replacing sensors? is there a way to hook up a diagnostics tool? I was so excited and now I'm so bummed out. Also bough a timinig light from HF but its a piec of junk couldnt even see the marks. I don't know if I'm crazy but the manual says my dizzy should be like this

 

But mine looks like this

 

which seems not exactly but more like this

 

Also how are you supposed to adjust timing when theres a tab on the dizzy that won't let it move past the bolt (its almost like it alings it. Well sorry to keep posting this I'm just at a lost and had a wheel'n trip planned for this coming weekend and I'm kinda dissapointed cause it looks like the MJ isnt gonna make it. Thanks for looking and any comments PEACE

Link to comment
Share on other sites

If it suddenly started acting up odds are the timing/dist indexing is correct. You can hook the 2.5 to a scan tool but it doesn't tell you much beyond what you can check with a multimeter (and the computer has no memory). A fuel delivery problem sounds more likely. My '87 2.5 had a few contributing issues that caused a similar problem. My OE fuel pump was starting to go though you could have a clogged regulator/injector/injector passage as well. Also just because you picked up a Reman injector doesn't mean it's any good. I've had a bunch of bad reman parts over the years. If you need other parts I have a spare 2.5 TBI minus the IAC. Just let me know.

Link to comment
Share on other sites

any update on this? check the EGR valve. if it is sticking open or bleeding past the seat it will cause a low/ rough idle and possibly stalling. especially since you felt some stumbling going down the hwy. did you use correct tune up parts (ie, not platinum plugs)?

Link to comment
Share on other sites

i changed the egr the other day and it ran a little better but still missing. i gotta check the dizzy again t hough cause in all the chaos of trying and trying and trying to figure things out i pulled the dizzy off and now I'm not sure if i put it back on right (position wise). :wall: :wall: :wall:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...