Jump to content

alt + battery question


Recommended Posts

Was driving today allot around town and the battery light came on. Noticed the wipers were getting slow truck was running fine so I went to Advance auto. Battery was 4 yrs old they tested it and said the battery and alternator were both bad. Is this possible or were they trying to sell the battery also? I myself did not believe them so I asked them a couple of times are you sure. Well I did buy the battery light is still on and there tester says no charge at all. Is there anything else I should do before buying a new alt??

Link to comment
Share on other sites

Check ALL your mains connections on the alternator, battery, starter, and body/frame grounds. Take them apart, clean the connectors up, apply some dielectric grease, and reconnect tightly. Inspect all the charging cables and wiring for burnt insulation and possible shorts. Then fully charge the battery, start her up and measure the voltage across the battery running at an RPM of 1500 or so. You should read at least 13.3 VDC. If not, the alt is probably shot.

Link to comment
Share on other sites

well when driving with a bad alternator, every battery will test bad untill returned to a charged state and then tested. but, it is very common, for a battery to go bad when an alternator does. sounds like your alternator is bad, and 4 yrs on a battery is good these days.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...