Jump to content

4.whoa

Members
  • Content Count

    11
  • Joined

  • Last visited

About 4.whoa

  • Rank
    Jeeper

Profile Information

  • Gender
    Not Telling
  • Location
    Michigan
  1. When I went to the shop, he said he didn't know jeep ever used them & "that's 60's technology" he then said the one thing he could do with it was " throw it away" It turns out my output bushing is all but gone, so i'm going to get that done first.
  2. This. My 2WD driveshaft did the same thing. I was worried it was the shaft. guess I need to find a shop. Thanks for the help everyone :thumbsup:
  3. I just checked and it seems straight
  4. I have a '87 4.0 auto 2wd. It hasn't really been out of town for several months, and on the last road trip, aside from the cruise, it was fine. It now has a vibration above 60mph. Naturally, I checked the u-joints.... they were fine, however the slip yolk moved a lot. Also, when I wiggled it there was a slight metallic clunk from the driveshaft. then I noticed this.... ( I noticed this after loosening the bolts :yes: ) While I did paint across the yolks, I did not put the arrow there. It kind of looks like the driveshaft is maybe starting to separate, to me. Has anyone had
  5. Its just a factory 97-01 XJ washer bottle. There's some write ups on swapping it. The only thing you really need to do is to drill a hole in the inner fender for the fill neck, and lengthen some wires and hoses. Thanks! You do some nice work :thumbsup: I appreciate all your pics I'll be able to get into altering my front axle as soon as I get into my shop, hopefully just a few weeks. :banana:
  6. was driving my 95 xj from MI to KS. noticed noise from steering pump when I pulled in for gas. fluid was fine, so kept going. an HR or so later, some oil started spraying up from the corner of the hood. when I popped the hood I found the steering pump shelled out * took pic after I pulled line off. I have a semi. I had been hit by some crazy chick, so while waiting for the insurance $$, I had an old tire on it. it blew @ 73 mph. it opened the hood , blocking my vision, when it blew I was in the right lane & it pulled me to the left shoulder. thank God it was 1am and the road was
  7. FWIW I went through DE inspection with a 90 MJ that had the egr blocked off. They had the hood up poking around. they clamped the vent line & pressurized the fuel tank. It failed. I had to pull the tank & run a new vent hose, but after that, it passed with flying colors.... I didn't know it, but at the time my cat was burned out. when I pulled the exhaust only a few weeks later, I could literally see through it like it was pipe. the honeycomb was melted into a pile at the bottom. :dunno:
  8. Looks great! Awesome work on that shifter! :thumbsup: What did you get that washer bottle from?- that was a great idea! I wasn't able to bend my brake lines tight enough to fit the stock one back in when I swapped to the WJ booster / MC I'm glad to see it staying 2wd :thumbsup:
  9. I passed an unmarked cop so fast one night it took him about 5 seconds to hit the lights ( back in my youth ) 1st thing he said was "I was doing 85! " :doh: Thank god he was pretty cool though... In my chally, I've only wrapped out 4th gear so far...
×
×
  • Create New...