Jump to content

No start after new IAC and O2

Recommended Posts

Last week I cleaned my throttle body and installed a new IAC and upstream O2 in my 89 4.0. After installing everything worked great and my idle was a perfect 700 rpm. Driving the truck around and it warmed up I noticed my idle would go to 1200-1500 when warmed up. I drove the truck for probably about a 5 days like this and made a 180 mile round trip during this time period with no issues besides the high idle. 
I dug around on the forums and found that most likely I had a leak on my manifold that was causing this warmed up idle increase. Sure enough, the back bolt was loose and the bottom nut in the back was missing entirely. No big deal, I tightened the bolt and threw a new nut on the bottom and hand tightened them just to see if they would fix the issue and I would retorque everything if it was. 
I go to start the truck and it’s totally acting up. It barely idles at about 100rpm before misfiring, burping and eventually choking out after a few seconds. When it’s doing this, no amount of opening up the throttle will have any effect. Additionally after I turn it off it stinks of gas. 
Now I have undone the nut and bolt tightening as well as unhooking the IAC plug to see if either of these fix the issue. No dice. My vacuum lines have all been double checked and we’re completely replaced in May by myself. I have also tried clearing the computer by unplugging the battery and grounding the truck out. Since making this post I have re-tightened the nut and bolt thinking they’re probably not the reason for this and it’s either probably the IAC being faulty or possibly a massive coincidence of the distributor crapping the bed. 
I’m thinking I’m going to remove the IAC completely and see if I can get an idle at all, but otherwise I’m at the point where I might have to just process of elimination the thing. To me I’m getting the idea it’s either an issue involving lack of air or lack of timing. But I would love and appreciate any insight given. 
the video I added (if it posts) is what I’m dealing with when it turns over. 

Link to comment
Share on other sites

After spending the better half of the night brainstorming and climbing under to look, it hit me. I thought all those hours browsing would tell me a no start should always start with the CPS before firing randomly at it. Sure enough I go under there and see the CPS wire was hanging in my workspace. I reach back and feel a one bolt is missing and the other is loose enough to hand tighten. I dug out another bolt, tightened them both and she fired right up with that perfect idle now. 

I guess in the perfect storm, an already loose CPS was knocked out enough with the movement in there and sure enough it fixed the issue. If nothing else I hope this helps others in the future!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...