Jump to content

front end noise


Recommended Posts

finally going to be replacing my track bar this weekend, but my luck more is going wrong :doh: . i think its with my drag link, because when i turn the wheel i here a bang that sounds like metal on metal, i looked an the bushing between the drag link and the pitman arm is shot. Also, when i'm driving and hit bumps it makes the same noise, but thats all it does is make noise. It doesnt effect my steering or anything :huh???: . i'm hoping the track bar fixes some of it, but while i'm down there i figured i would ask advice from some of you guys. :cheers:

o an i checked and nothing is loose, and nothing is broken from what i can tell

Link to comment
Share on other sites

It's not a bushing, it's a Tie Rod End connecting the draglink to the pitman. If there's slop in that, that could definitely cause a noise. I imagine it would somehow affect your steering though.

 

If your trackbar is shot, there's a good bet that's your noise. Get your trackbar changed out, and take it for a spin. If the noise is still there, let us know.

 

Another good bet could be your balljoints. Get the wheels in the air, hug'm, and shake like hell to see if there's any play.

Link to comment
Share on other sites

ok, i wasn't sure if you could swap out just the bushings instead of the whole end, but that is definitely going to have to be replaced. The track bar bushing is also bad at the upper mount, so the Currie bar will probably help that. I was also planning on checking the ball joints and wheel bearings while i'm at it, cause after about 40 the front end vibrates, and only gets worse as the speed increases, thanks for the knowledge :cheers:

Link to comment
Share on other sites

Got the track bar in today :banana: , a bit of a pain, but its in. Helped some, but i still get the noise when i turn it pulling out of driveways, when i'm going slow an turning sharp, still seems the the drag link to me, but :dunno:

Link to comment
Share on other sites

ok, i wasn't sure if you could swap out just the bushings instead of the whole end, but that is definitely going to have to be replaced. The track bar bushing is also bad at the upper mount,

There are no bushings in the tie rod ends, or at the upper (frame) end of your track bar.

Link to comment
Share on other sites

Mine was coming from that bolt at the pitman arm and the rod ends are shoty .

 

The bigger tires put allot of wear on old stock components . All my noise came after I put the 31" on a 200,000 mile suspension .

 

NO BUENO !!!

 

Do the WJ upgrade or look at Tera Flex for their high steer kit , way better than the stock components .

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...