Jump to content

floridaftwman

Members
  • Content Count

    53
  • Joined

  • Last visited

About floridaftwman

  • Rank
    Comanche Fan

Recent Profile Visitors

56 profile views
  1. I don’t have the space or resources to store the seat and rip the carpet up, just yet. Stay tuned. Tore the lights up again to test the right side hi beam. Just a bulb, thankfully. Edit: gave everything a good whiff of contact cleaner and finished swapping the headlights, and sure enough the high beams on both sides are working. Went for a drive before I tore the lights out. I’m not sure how bad the gas gauge is off, but it’s off. By a quarter of a tank, I think. When the tank is full, it goes well past the full indicator. It’s gotten just under the quarter tank mark twice and shut off on me while at an idle. Guess this would be a good time to take it out for a ride with a couple gallons in a can. Sent from my iPhone using Tapatalk
  2. a little bit of “life happens” happened today. But I got the parking light sockets temporarily installed. Probably doesn’t matter. I think my first move going forward is to address the moisture in the cab. Sent from my iPhone using Tapatalk
  3. Thanks for the input. I was able to release the brake using eagle’s suggestion. Sent from my iPhone using Tapatalk
  4. good deal for 8 bucks. Sent from my iPhone using Tapatalk
  5. Parking lamp sockets arrived from Quadratec. Plan to install them on Sunday. Have to make room to store the bench seat before I can rip the carpet up. Hoping to start that on Tuesday. Found a member with some stock rear fenders for 40 bucks, shipped. Will probably nab those and order the Euratecs this weekend. Narrowed down the running list to the priorities: Lights Ground refresh Moisture in cab Suspension/alignment/steering Parking brake Driver side door check Fuel leak Blow by Exhaust Leaking seals I’ve had the truck for 6 weeks. So far, I’ve driven it a thousand miles, compiled a list of known issues, and almost restored function to the lights. Gonna try and pick up some steam over these next few weeks. Sent from my iPhone using Tapatalk
  6. Parking brake cable broke (haven’t narrowed it down yet). Thanks to eagle and the following thread, I got the parking brake released. https://comancheclub.com/topic/58741-parking-brake-stuck/?tab=comments#comment-602889 The two cables that split off to the wheels appear to be intact and I think it’s the main cable that’s broken. Sent from my iPhone using Tapatalk
  7. Where was the moisture coming from? Are there any spots I should check? I’ve driven in the rain and don’t see any obvious leaks, but I know that doesn’t mean squat... Sent from my iPhone using Tapatalk
  8. I didn’t pull it back much, but I did notice some moisture... no standing water, but the rubber was damp. I’m debating if I wanna use this as an opportunity to address that as well. Sent from my iPhone using Tapatalk
  9. lol. I guess it’s a matter of prioritizing what work I do on it. Sent from my iPhone using Tapatalk
  10. Actually, the mechanism (pedal and release) work fine, but they’re just not releasing the actual parking brake. Sent from my iPhone using Tapatalk
  11. Pulled the trim off and some of the carpet and rubber up to see if there is a way to manually release it. No dice. I feel like I read something about it on here, but none of the parameters I’ve searched returned any results. Haynes seems like a lot of work I don’t have time for. Sent from my iPhone using Tapatalk
  12. Went to move my MJ today and found that my parking cable broke and the emergency brake is stuck. Didn’t have the time to release it.... Sent from my iPhone using Tapatalk
  13. Welcome to the club! Sent from my iPhone using Tapatalk
×
×
  • Create New...