Jump to content

hbhp5

Members
  • Content Count

    8
  • Joined

  • Last visited

About hbhp5

  • Rank
    Jeeper

Profile Information

  • Gender
    Male
  • Location
    FL PanHandle
  1. Will do, thank you so much. Will let you know when we're back on the road.. JohnA
  2. Soooo, finally got the bracket, pump, etc. Hooked up, but, old belt is too long. Bought a belt for 98, it's too short. Any ideas~? Part numbers~? Thank you, JohnA
  3. Soooo, finally got the bracket, pump, etc. Hooked up, but, old belt is too long. Bought a belt for 98, it's too short. Any ideas~? Part numbers~? Thank you, JohnA
  4. I have a 91 Comanche 4.0. Just installed a high output intake plenum. Now power steering pump mounting bracket doesn't fit. Is there a different bracket for this set-up~?
  5. Cleaned & Dried Connector, Re-Assembled, Good as NEW~! Not bad for 350k miles. Replies MUCH appreciated. John
  6. hbhp5

    Prayers needed

    Prayers to our Creator.
  7. 91 4.0, Was in town, stopped at store, came out, started, and seemingly out of NO where would not accelerate. Limped home (8 miles) with several times had to pull off road, NO power. Fuel pressure test showed 15#, replaced pump, now 41#, but, still no power. Will idle rough, try to accelerate, stumbles and blowback etc. 2 yrs ago similar problem when cold was computer connection, cleaned terminals and used dielectric grease on re-connection, NO go. Timing chain, distributor assy, ALL sensors replaced 2 yrs ago. ANY Ideas world be appreciated.
×
×
  • Create New...