Jump to content

Q's about Tranny Problems (I think)


Recommended Posts

Alright guys well a couple weeks ago during a snow storm something happened to my 86' 2.8l TF904 4x4 don't know when it happened but I was on my way home and noticed I was leaving a blood trail. By the time i got home (a mile after I noticed it) I limped in but was loosing power to the wheels. I hoped it might just be because it was low on fluid and I had just busted a tranny coolant line or something but no luck. It seems to be something else. I am not real experienced with this type of problem. Anybody have any thoughts? Is my tranny shot?

 

Next Question.... If my tranny is shot what are my options on replacing it. Is there any possibility of finding a transmission with a 4 or 5 speed. This thing as it is feels like its going to explode when I'm at 50 or 55 mph.

 

I only have about 90,000 miles on the truck and really love it regardless of the water leaks i can't seem to find and the lack of power but it's rust free and drives pretty nice still.

 

Anybody have any thoughts or answers to my questions?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...