Jump to content

M.O.R.E. steering box brace installed!


Recommended Posts

Finally got this weird thingamajig in place with one problem in my eyes...

 

Here you can see where I had to grind down the end of the brace and make the hole way bigger:

PICT9985r.jpg

 

This was so that the hole on the brace and the two holes in the straps. The brace right out of the box did not fit what so ever (here it is modified to fit):

 

PICT9988r.jpg

 

MORE could have engineered it better and saved me an extra 1-2 hours of work. Probably would take an extra 5-10 minutes on the manufacturing end...

 

Anyway it is installed and hopefully it will keep my box in place :redX:

 

PICT9991r.jpg

 

What do you think? :nuts:

Link to comment
Share on other sites

it wasnt MOREs fault man, we've got a rusty's (same identical setup) steering box brace and it didnt fit out of the box either. we chocked it up to the catastrophic hydroplaning incident and other accidents the XJs been through

 

edit: we also bought a RE frame stiffener for the new RE trackbar mount and stuff on the same X and it didnt fit AT ALL either

Link to comment
Share on other sites

I'm gonna say that by how bent up the front of the frame is (as pictured in your pic), that it's not MORE's fault either. maybe your rig was in an accident and it's tweeked just a little bit.

 

 

also, I'd slide the end of the brace between the two clamps rather than bolted onto the side. it would offer more supporet I think.

Link to comment
Share on other sites

I'm gonna say that by how bent up the front of the frame is (as pictured in your pic), that it's not MORE's fault either. maybe your rig was in an accident and it's tweeked just a little bit.

 

 

also, I'd slide the end of the brace between the two clamps rather than bolted onto the side. it would offer more supporet I think.

 

Woops...you caught me. I did leave out that my manche was in an accident (PO!!! :roll: ) So yes I suppose this would affect the fitment.

 

Now I tried mounting inbetween the straps and it was rubbing on the flywheel horribly. This is the only way it mounts up (on my truck anyway). :cry:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...