Jump to content

4x4 vent and oil preasure


Recommended Posts

first off what is a normal oil preasure reding.mine has mobil 1 10w 40 in it and runs about 40 cold at idle and 15 warm at idle.usually runs at 2200 rpm and at 25- 30 psi.also when i disinguage my 4x4 the light stays on and the axle is still inguages till i drive it a few blocks.i just put a new switch and vent in it.is this normal?

Link to comment
Share on other sites

Factory spec for oil pressure (with a warm engine) is 13 psi minimum at idle, and 37 to 75 psi above 1600 RPM. In general, most decent Jeep engines seem to idle between 20 and 30 psi and run 45 to 55 psi at high way speed (around 2000 RPM). Yours sounds a bit on the low side, but not fatal.

 

With the front axle disconnect, it's not unusual for there to be some delay unlocking, but several blocks is a bit extreme. I have found that, if traffic permits, unlocking is more reliable if I can stop and back up for a few feet, then go forward again.

Link to comment
Share on other sites

not a bad idea.the only reason i didnt do that is because fuel mileage which probably isnt noticable and my 4x4 light.well actually the 4x4 light would still work if i leave the vacume lines.maby i will do that because the lines froze up on me a couple times this winter and i didnt have 4x4.its like haveing a cheap posi lock without pulling a cable.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...