Jump to content

running/stalling problem, but only in 4lo


Recommended Posts

So I went to my club's BBQ yesterday, and I went to throw it in 4lo and it stalled the instant I put it in D. So I tried again, and the same thing happened. I then started it again, an put it in R to back out and it went just fine....then I tried D again and it stalled.

 

Yesterday it was just stalling, no sputtering. I could neutral drop it, and after one lurch it would run fine...but if I came to a stop, put in R or P, then back to D it would die (if I didnt do a neutral drop at ~2000rpm) I looked at the TPS and checked the voltage, and it was in spec (.70v). This morning after fiddling with some stuff and not really doing anything, it started to sputter and lurch in 4lo, but only when the brakes were on.

 

The funny thing is that in 2hi and 4hi....it goes fine, but does sputter in 4hi some times....very rarely though. There is plenty of fuel in the rail, and when in N or P, if I rev it, there is no hesitating or sputtering indicating low fuel pressure. I know the torque converter is not causing this problem.....but I have NO idea what else it could be. I need to get this fixed soon, so any help would be appreciated

 

ANY ideas!?!?

 

88MJ, 4.0, 231, AW4.

Link to comment
Share on other sites

I've looked at the linkage a lot and there appears to be no wire shorting out.

 

I have it up on jack stands now, and when I put the Jeep in D and in 4LO, and leave the engine OFF, I can spin one wheel, and they all spin (I have lockers). Someone suggested that the t-case might be jamming in 4LO while going forward. If I start the Jeep and put it in D (while on the jack stands) it will go fine, but if I put my foot on the brake it will stall immediately. If I give it gas it will sputter a little.

 

anybody?!?!!?!?

Link to comment
Share on other sites

I will recheck the vaccume lines. Thanks. I'm so depserate now...even suggestions of places to look is a huge help, because I've played with it so much, that I don't know what to do anymore.

 

I read somthing about the NSS causing the issue, so I bypassed it and NOTHING. I tested the resistance on the solenoids in the transmission, and one read 13ohms and the other two read about 8ohms. I don't know if this is from a bad ground or what...but I used the same ground for all 3 wires ???

 

I've cleaned the IAC, bypassed the ballast resistor, adjusted the TPS, removed almost all the exhaust (looking for some sort of clog), and tried a different battery. I unplugged the O2 sensor, and the same thing happened. I have another 02 sensor that I will throw in for the helluvit. I'm so baffled. It really appears that the torque converter is locked while in 4lo...but its impossible for the torque converter to lock in 1st gear on the AW4 (even when I tell it to...it doesnt). Even on the jack stands whe the brake is depressed it will stall. If I shift into D without the brakes on, then go into D it will sputter REALLY bad. I'm wondering if its a fuel pump...but wouldnt it do this in ALL gears, not just 4lo?

Link to comment
Share on other sites

I think its a transmission problem. I was having a discussion on my club's forum, and one guy (Derek actually) had an identical problem, and it was the tranny.

 

Woohoo, I managed to kill an AW4. The exhaust melted a transmission cooler hose on route 2 resulting all the atf being spilled on the exhaust and smoking like a bastard. I think this has somthing to do with the problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...