Jump to content

Moffat007

Members
  • Content Count

    22
  • Joined

  • Last visited

About Moffat007

  • Rank
    Jeeper

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Please look for the previous post for detail My loss is your gain - for damn sure Sent from my iPhone using Tapatalk
  2. Shipping is around 1k - I’ll pay half is you want to make a deal Sent from my iPhone using Tapatalk
  3. Good running condition, stock standard. New windshield,New fuel pump and sending unit, new clutch, new tires, new sensors all over,New cat converter (CA approved)new muffler new exhaust pipe. Bought and tuned for my daughter. She is not comfortable with the manual shift. Sad to let it go, I need it gone ASAP. I posted it For sale about a month ago for 3800 but I am willing to take less for it. 2400 or best offer! Come on guys make me an offer. I can deliver if you cover the gas. Sent from my iPhone using Tapatalk
  4. Thanks man, sad to let her go Sent from my iPhone using Tapatalk
  5. Sent from my iPhone using Tapatalk
  6. Good running condition- stock standard. New windshield, new fuel pump and sending unit, new clutch, replaced 90 % of the sensors OEM, new muffler, new exhaust, new cat(CA approved). I am in the Sacramento area California. Bought and tuned it for my daughter. She doesn’t t like the manual shift- and she wants it another color. Ha ! Not spending more money on it and I’m ready to let go. $3800 Sent from my iPhone using Tapatalk
  7. Huck731 - did you find one to buy ? I'm thinking of parting with my '89 2.5 2WD if you are still interested. It is in good running condition. Let me know, I can post more pics if you want
  8. She has about 220 000 on the clock. But running smooth - no hesitation, no misses , very responsive. Sent from my iPhone using Tapatalk
  9. Hey everyone, finally got the 4 cylinder running. Installed new cat, muffler. Unfortunately did not pass smog. In fact The tester could not give me a report but told me that it’s polluting because it’s too overly rich. Could not get an accurate reading . I agree that it is rich. But where do I start ? In the resurrecting effort I replaced the following- O2 MAP Temp Vacuum pipes Fuel pump and assembly ICM CPS I don’t want to drive it to spare the Cat. Can it be the EGR that is causing this ? Or the Fuel pressure regulator? Manifold ? Carbon build up in the combustion chamber I spent a lot of $ and time already [emoji85] James Sent from my iPhone using Tapatalk
  10. That one on the side wàs the coolant temp sensor when I screwed it out, coolant leaked out. Sent from my iPhone using Tapatalk
  11. Big thanks to everyone, problem solved . I replaced all the sensors mentioned above - but the problem was the autozone fuel pump all along - I bought a new one from NAPA and now she’s running like a champ ! Sent from my iPhone using Tapatalk
  12. So mine has two - I guess one for the gauge and one for the comp? Sent from my iPhone using Tapatalk
×
×
  • Create New...