Jump to content

dmatt5656

Members
  • Content Count

    14
  • Joined

  • Last visited

About dmatt5656

  • Rank
    Jeeper

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. dmatt5656

    Water pump

    My 1990 Jeep Comanche has a leaky water pump what's the best water pump to use? Its a daily driver Sent from my moto g(6) using Tapatalk
  2. dmatt5656

    Electrical problems

    So I had to fix my loose steering column before I could dive into my ignition switch because it needs to be in acc to replace it if I'm reading the directions correctly. Well I can't turn it back to ACCbecause of the trim around the column is being pushed back by the peice that actuates back when the key is turned. Idk what it's called it's got teeth on i left side of the column Sent from my moto g(6) using Tapatalk
  3. dmatt5656

    Electrical problems

    Okay thanks man I appreciate it Sent from my moto g(6) using Tapatalk
  4. dmatt5656

    Electrical problems

    So everything works on ACC. I got my brake lights back. I put a new ground in the driver's side tail light. Still no heat turn signals radio or wipers Sent from my moto g(6) using Tapatalk
  5. dmatt5656

    Electrical problems

    Horn is missing the spring to make it work but it used to function. I lost the spring and just haven't fixed it yet. And to be honest I hadn't thought about checking if they work on ACC Sent from my moto g(6) using Tapatalk
  6. dmatt5656

    Electrical problems

    Yes it runs fine. No bad fuse. And it's a manual Sent from my moto g(6) using Tapatalk
  7. dmatt5656

    Electrical problems

    Sorry man I'm at work. Like I said. Bear with me. It's a 1990 4.0 Sent from my moto g(6) using Tapatalk
  8. Okay so I'm kinda in a hurry so please bear with me. On my way into work this morning my comanche was running normal and everything was working. I shut it down to go into the store. When I came back out and started it up only my headlights dash lights ashtray light and dome lights were working. My heater, turn signals, radio and wipers suddenly weren't working anymore. Idk what the problem is. Please help winter is coming and I don't fancy freezing my boys off Sent from my moto g(6) using Tapatalk
  9. dmatt5656

    Valve cover?

    Thank you. I wouldn't mind some pictures of this at all ha. Sent from my Z982 using Tapatalk
  10. Okay so I have a 1990 jeep Comanche Elminator 4.0 it's my daily. I also have a 2000 Cherokee donor. My problem is the valve cover on my Comanche is leaking and not around the gasket. And today I discovered that my oil cap seems to have disappeared. So my question is Will the valve cover from the 2000 fit on my 1990? Sent from my Z982 using Tapatalk
  11. dmatt5656

    MJ/XJ Specialist Mechanic

    I am wanting to get rid of my unnecessary vaccum lines and replace with something a bit more durable. Silicone? I don't know I haven't been able to find anything on this. Sent from my Z982 using Tapatalk
  12. dmatt5656

    23gal Fuel Sending Unit

    Delphi Sent from my LGMP450 using Tapatalk
  13. dmatt5656

    23gal Fuel Sending Unit

    I do have a question though. My fuel pump has been whining since it was installed. Is there any way to stop this? Sent from my LGMP450 using Tapatalk
  14. dmatt5656

    23gal Fuel Sending Unit

    Mine currently reads backwards. Its pretty accurate though Sent from my LGMP450 using Tapatalk
×