Jump to content

Jeeperscreepers

Members
  • Content Count

    3
  • Joined

  • Last visited

Everything posted by Jeeperscreepers

  1. 1988 Comanche Pioneer Short Box 4X4 Engine: 4.0L Renix Transmission: Peugeot ba10/5 Transfer Case: Np231 Front Axle: 1994 XJ Dana 30: 3.55 Rear Axle: Dana 35: 3.07, (Soon to be Chrysler 8.25 3.55) Color: Dover Grey Mileage: 104k Location: Alabama This is my work in progress that I bought a few months ago. It's a clean 88 mj, no rust, small lift, and 32" tires. I did a small restoration on it (painted it, decals, tail lights, ect). The interior is all original and it has 104k actual miles.
  2. My plugs still look new, and it doesn't smoke at all. Went to the boneyard and picked up another ecu. Swapped it and haven't had any issues for the past two days. Starts and idles perfect. Guess my problem was the ecu.
  3. Interested to see if a solution to this problem can be found, I have the same issue with a 88 4.0l renix MJ. On cold starts the engine turns over for probably about 6 seconds before starting and does not rev up to 1k and come back down to around 750, instead it stumbles to life and idles around 150 rpm and after a minute or two it adjusts to 750 rpm. Sometimes I have to give it a little throttle or it will stall before the idle comes up. About 40 percent of the time the truck will continue to idle too low after stumbling to life and never idle at the correct speed. Rarely when it gets warm it will idle too high(1200 rpm). This problem seems to be intermittent, If the engine is warm and the idle is too low(300-400 rpm) and i shut it off and restart the engine the truck fires right up to 1000 rpm and comes down to around 750 and idles normal. Also it should be noted, Other than the strange idle the truck runs fine, No miss fire, or skipping, or loss of power, runs down the road fine. -NEW IAC -NEW TPS, adjusted correctly -Perfectly clean Throttle body -NEW MAP, with new map vacuum line -NEW Plugs, wires, cap, rotor -IAT Checks out -CTS Checks out -CPS Checks out -EGR is deleted -02 sensor checks out -C101 is deleted -All grounds have been cleaned and refreshed -Fuel Pressure is good -Swapped all the relays out, no change -NEW intake manifold gasket and the bolts are torqued to spec -Previous owner redid most of the vacuum lines, can't find a leak -Has a REMAN BENDIX ECU that was installed back in 2002
×
×
  • Create New...