Jump to content

Truck not having required power


Recommended Posts

So my truck won't run currently. All the lights inside have power but the radio and other things don't. When I go to crank it it dosent turn over at all. So I replaced the starter relay and still nothing. What should I do?

Link to comment
Share on other sites

Fuse links are wires coming off of the starter relay, they are wires that act like fuses.  The ignition switch is on the column about half way down on the right side.

Link to comment
Share on other sites

17 hours ago, PocketsEmptied said:

Are you getting 12v to the red wire going into the switch?

Not sure I got a new ignition switch but now I can't even get the new one to turn over properly like the old one would 

Link to comment
Share on other sites

7 hours ago, Muncher said:

Not sure I got a new ignition switch but now I can't even get the new one to turn over properly like the old one would 

So you replaced the ignition switch and the starter relay? Did you adjust the ignition switch? Do you have power on the red wire

Link to comment
Share on other sites

Hadn't gotten to check the red wire yet but I got the new ignition switch and I can't get it in properly so I'm just going to have to bring it to a shop and have them figure it out sadly 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...