Jump to content

Recommended Posts

The gauge dances a little but it’s all in the red area.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
16 minutes ago, Dammerung said:

Is there a chance the gauge is just bad?


Sent from my iPhone using Tapatalk

 

It worked before I made the changes in the truck but hey, when something goes bad, it just goes bad. 

 

Are they replaceable if they do go bad?

Share this post


Link to post
Share on other sites
Yes. Should be some screws holding it in place. You could always apply 12V to it and see what it reads.

Yeah, I’d try that. It’d suck if it had just decided to go out now if all times but better the gauge then anything else more important.

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
Guess its a good thing that style was used until 96. PS 3 left as NOS if the gauge really did go south.


There’s some good news.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Wouldn't be the first time I've seen a Renix era dash gauge go bad. On my blue cluster, I had two bad gauges.

 

Will see what I can come up with on your radio wiring. Would have been a lot easier if you would've used an adapter.

Share this post


Link to post
Share on other sites
Wouldn't be the first time I've seen a Renix era dash gauge go bad. On my blue cluster, I had two bad gauges.
 
Will see what I can come up with on your radio wiring. Would have been a lot easier if you would've used an adapter.


I need to take a picture of the front of the factory radio that was in it. All the factory dash wires had been cut and spliced into that unit. I had to cut the wires to get that unit out. I would say the radio in it wasn’t the one that came in the truck because it had a mark on it like it came from a JY. The truck has aftermarket speakers and I bet it had an aftermarket radio but it was taken out at some point. The actual plug that went into the radio had wires taken out of it according to the wire diagram on the radio.

5d135cc00c40aa25be1eb04620cd35de.jpg


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Drove it to work again today. Man it just feels good to drive it. I rechecked the alternator when I got to work and it it’s still charging so rock on!!!

I’m just glad to drive it. I love this little truck!!


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Poser pic from down the road.

Yes this is from the road I live on.

0a41e100f0df30f9184287baaf952b59.jpg

Creek crosses the road.....

410f85181b2088bf04f06cacf014426f.jpg


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...