Jump to content

Recommended Posts

Oil is in the air filter, have had an impossible time finding the ccv or pcv elbows and grommets for the vault cover. Used the ones i ordered from jeep and made it work with black gasket maker.  Air is only coming out of the defrosters and is very weak when  temp is set to max heat, replaced many vacuum lines and still nothing. Replaced a/c control unit still nothing. found what makes the vents change under the driver side dash and was able to get it to switch manually but will not stay. driver side door is to low and is ruining my fender. Truck will not heat over 150 F making the heat weak. is there supposed to be a backup light, because there isnt. pictures can be added as needed 

Share this post


Link to post
Share on other sites

So many questions. This should probably have been posted as several individual questions, but here goes:

 

  1. Oil in the air filter is caused by engine blowby. There's always some, and the CCV system (the 4.0L doesn't have a PCV valve) can handle it when the engine is new and the blowby is minimal. As the engine wears, the amount of blowby increases until, eventually, the CCV system can't handle it. At that point, the excess blowby pressurizes the crankcase, and the back pressure then blows oily fumes back through what is supposed to be the air intake from the valve cover to the air box. If you're having a problem, I'd suggest doing a compression test and a leak-down test.
  2. Air from the defroster vents is the default position. If you have air from the defrost vents when the controls are set for something else, you have a vacuum leak. There is a vacuum reservoir (or should be) located behind the front bumper, on the right hand side. Often the vacuum line to that reservoir rots where it passes under the battery tray. Or, your reservoir may be cracked and incapable of holding vacuum.
  3. Replace your thermostat, and be sure your cooling system is properly filled.
  4. Yes, there should be backup lights. The clear section in each taillight is the backup lights.

Share this post


Link to post
Share on other sites

I have replaced termostat, changed nothing. Thanks for the vent tip, they now work. I'll have to research those blowback test u mentioned, but thanks for the info. Below is the ccv elbows I used because they came from Jeep and still didn't fit. We have to same mj also😀

15526703120361799861609.jpg

15526703363552090720682.jpg

Share this post


Link to post
Share on other sites

Also I have replaced vault cover gasket and oil filler cap yesterday, so maybe one of the two helps. Going to replace filter and wait and see. I'm just bothered by the makeshift ccv elbows.

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...