Jump to content

Recommended Posts

So I learned a lesson with interior lights don't use LED it creates havoc as Jeep ground the interior light circuit through the actual bulbs. (Similar to the front turn signals)

 

20200620_213641.jpg.b4758078907f2ccd7c568c1b810490be.jpg

 

Had some fun with the clock. My harness wasn't wired for it. Found this great article that explained all the various clock pin out's - Lifesaver

http://gojeep.willyshotrod.com/HowtoDashClock.htm

 

20200620_213947.jpg.56c9f2e53473f1b323d0104bc03bcacc.jpg

 

Installed the bed lights. Tied into the cargo light circuit.

 

20200620_213824.jpg.aa506fad411ac422658228c3b08b537d.jpg

 

Fluids arrived getting closer. Just need to bleed brakes, check clutch and finish adding clutch switch for cruise control,, add fluids and fire her up!!

 

20200620_213418.jpg.0d3454ca7c9724ae131955cc66deac0d.jpg

 

 

Share this post


Link to post
Share on other sites

So finally I have a living, breathing 5.3 L33 all aluminum engine running in the Comanche. quite a journey. I did learn today that you cannot start a new LS if you do not depress the accelerator pedaL. Apparently the LS  engine will not start until it sees TPS voltage movement. New one on me. Got a couple of small coolant leaks. All the gauges work which is a miracle!!. Off to the exhaust shop next week.

It is an amazing experience that far too few get to experience.

 

 

 

 

Share this post


Link to post
Share on other sites
19 minutes ago, Limeyjeeper said:

you cannot start a new LS if you do not depress the accelerator pedaL

 

Weird...I don't have that issue. o_O

 

It's so exciting to hear it run the first time...loud, but exciting!  You're going to love driving it!

 

Share this post


Link to post
Share on other sites

I can't wait. I am going to have to pull the trans. The clutch isn't quite right. I need to wind in the adjustable thrust bearing a bit. Brakes are bled, PS is all good. No leaks so far. All gauges are working. Gas is reading double what it should because I think tristarradiators used an XJ sending unit. Easy fix with a resister.

Share this post


Link to post
Share on other sites
13 hours ago, thecodemonk said:

 

Weird...I don't have that issue. o_O

 

It's so exciting to hear it run the first time...loud, but exciting!  You're going to love driving it!

 

It was only on the initial start, Had me baffled why it wouldn't fire. So I stabbed the throttle and bingo fired right up.

Share this post


Link to post
Share on other sites

Got the clutch dialed in. Not totally happy with the way I got it to work. Had to extend the Jeep slave cylinder rod by 2". Will probably pull the trans at some point and change the thrust bearing and bearing arm. Dealt with a bunch of leaks, mainly because I am not very good at tightening connections!! Learned that Wilwood's are a pig to bleed. 

Getting the exhaust done next week.

Got a leaking heater core (brand new) more Chinese junk. Luckily I was going to pull the dash anyway to wrap the wiring harness. Still annoyjng.

 

Share this post


Link to post
Share on other sites

daaaaaaaaamn... I bet that looks good in the sunshine :D 

Share this post


Link to post
Share on other sites

Been following this build for a long time and am super impressed at how it's been going.  Going to need more videos of that engine and some crazy burnouts.

Share this post


Link to post
Share on other sites
8 minutes ago, Chargum85 said:

Been following this build for a long time and am super impressed at how it's been going.  Going to need more videos of that engine and some crazy burnouts.

All in good time....lol

Share this post


Link to post
Share on other sites
57 minutes ago, Limeyjeeper said:

First time she has seen daylight in 18 months.

 

20200706_105403.jpg.607a16aa930fffc5d48c7e3702a4e581.jpg

 

20200706_105352.jpg.f7e32dcdb7c375475f5361b112900256.jpg

 

20200706_105346.jpg.3f11e0a0552157e32201eb31a4667b7e.jpg

 

20200706_105340.jpg.85976dadebf49c957a528638ba173105.jpg

 

Awesome build:L:

Share this post


Link to post
Share on other sites
1 hour ago, Quarterpastgone said:

This build has got me back moving on my own build. That is one sexy manche!!!!!!

Yours is none too shabby either!! Incredible fab skills.

Share this post


Link to post
Share on other sites
2 hours ago, Sir Sam said:

Looks sharp. What all is left for you?

Exhaust, finish the interior, test AC,  probably will need to play with the clutch release bearing some more. That is about it!! or and find a NOS passenger tail light!!

Share this post


Link to post
Share on other sites
5 hours ago, fiatslug87 said:

I see an MJOTM in your future. Very classy build.

As do I. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...