Jump to content

Cluster swap, fuel gauge stuck past full

Recommended Posts

I recently bought an 88 comanche with an i6 an aw4 column shift. It came with parts for a cluster swap and I had another clusters. When I swapped in the new cluster the fuel gauge went to full and is stuck there. I tried cleaning the contacts and grounds but still had the problem. So I swapped in another fuel gauge from another cluster, same thing. Then tried the original, still stuck past full.

I found a thread on here about removing the screws and turning the gauge and that didn't work either. Also found this one but no solution.

Is there a fix? or is it some wiring gremlin that needs to be found?



Share this post

Link to post
Share on other sites

Did the original gauge/cluster work properly before removal? If it did there's probably a problem with either the printed circuit board on the new cluster or the ribbon connection to it. Otherwise, there's probably a short somewhere (bad ground).

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now