Jump to content
IDMJ

Picaro......Sigh of relief

Recommended Posts

the fuel pump ground to the taillight ground.  make sure it's connected (or take this opportunity to add in a new ground closer to the fuel pump)

 

you should probably put the diagram request in the Tech forum so more eyes will see it.  I'm sure someone has something. :L: 

Share this post


Link to post
Share on other sites

Thanks for the advice. I found an fsm in PDF that I'm perusing now. This thing is really trying my patience.

Share this post


Link to post
Share on other sites

Added a ground to the fuel pump and, it's cycling now. But of course my gauges quit again.

Share this post


Link to post
Share on other sites

ahh, yes.  the joys of old jeeps. :( 

Share this post


Link to post
Share on other sites

Traced it down to a fuse in the pdc. Looks good, ohms bad..... Grrrr

Share this post


Link to post
Share on other sites

Got my fuel tank brackets done. I used the stock MJ tank straps and, cut new holes in the frame to match the new rails. TJ tank with XJ pump. Tank is out to have the fuel filler neck moved to the side to match the fuel door on the bed.

7910E73D-AC45-4E6F-884A-109E113FD393.jpeg

5C44DA54-6C24-49A2-9682-F783306AC2E0.jpeg

Share this post


Link to post
Share on other sites
7 minutes ago, 1989commanche said:

Looking good. Great work. 

Thanks. It's coming along slowly.

Share this post


Link to post
Share on other sites

love it!  when you're done, can you put together a DIY thread?  lots of guys are looking for fuel pump/tank alternatives. :L: 

Share this post


Link to post
Share on other sites
9 minutes ago, Pete M said:

love it!  when you're done, can you put together a DIY thread?  lots of guys are looking for fuel pump/tank alternatives. :L: 

We’ll see if my tank mod works but, I suppose I can. I hate being tasked ..... 😜

Share this post


Link to post
Share on other sites

Finally got my tank back from getting modded. Hopefully I’ll have it in and running this weekend. 

43341157-6C41-4E63-BA99-9ED0C6240152.jpeg

Share this post


Link to post
Share on other sites

got the tank in, fuel pump harness extended, fuel line bent up and in. I didn’t like the fact that there isn’t a fuel filter inline on the late model so, I am using the old renix inline filter also. I am really happy that the tank mod turned out exactly like I wanted. will hopefully get the charcoal canister in this weekend but, I’m taking today off for some rock crawling. 

313ABAF7-51E9-40BB-99FE-776C05F9D3B8.jpeg

Share this post


Link to post
Share on other sites
38 minutes ago, Pete M said:

holy smokescreen batman!

That’s the coating burning off the new header

Share this post


Link to post
Share on other sites

Saw daylight for the first time since September ‘18. I may take it for a short drive today 

1CB72895-7259-42B4-810F-E07AD9B8F92F.jpeg

Share this post


Link to post
Share on other sites

Got the interior trim painted and, have everything installed except the headliner which I haven’t re-covered yet. I love the way it turned out. I took it out for a drive and got P0171 code so, I ordered new O2 sensors. Hopefully that’s all it is.

BCF7EF4D-6773-426C-90EF-EB69B1E8821E.jpeg

2B0D18D0-4739-4889-856D-5E97CF2871B3.jpeg

Share this post


Link to post
Share on other sites

Well, got my O2 sensors in and took it for a 20 mile jaunt with no issues. I gotta say Brown Dog poly motor mounts are definitely noticable......

Share this post


Link to post
Share on other sites

can you feel the engine more than before?

Share this post


Link to post
Share on other sites
11 hours ago, IDMJ said:

Well, got my O2 sensors in and took it for a 20 mile jaunt with no issues. I gotta say Brown Dog poly motor mounts are definitely noticable......

You mean intolerable?

Share this post


Link to post
Share on other sites
35 minutes ago, Jeep Driver said:

You mean intolerable?

Not quite that bad. (Yet)

Share this post


Link to post
Share on other sites
11 hours ago, Pete M said:

can you feel the engine more than before?

Oh yeah. At first I was thinking that the O2 sensor didn't fix my lean condition and, it was still running rough. But those mounts transfer all the engine vibes to the frame. I was concerned about that when I bought them. It's really only noticable at a stop and in gear.

Share this post


Link to post
Share on other sites

Drove it to work all week(66 miles round trip) and no issues there. Had an airbag light and horn hasn't worked since I got the Cherokee prior to the swap. New clockspring fixed those issues. I'm pretty pleased so far. Now, if the weather would change for the better maybe I could start on some body work......

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...