Jump to content

Recommended Posts

Hey everyone, I finally decided to create a profile. I've been checking out the MJOTM every now and then but I just decided to create a build thread of my own. I've done a lot of work to my jeep and still have a lot to do. I figure I'll start off with a little backstory, then go through my build from the beginning. I plan on picking at this and updating the thread when I have free time. I'll post whatever pictures I have but unfortunately I didn't take very many. I never think about taking pictures until I'm done something :brickwall:. Anyway I have some long stories.

 

Here's the backstory: It's a Pioneer, 4x4, 4.0L, long bed. I've known this Jeep my whole life as it used to belong to my uncle. My uncle's father (married in uncle) bought it brand new in '87. Now this guy did not baby this truck! It's been rolled over on 2 or 3 occasions and it was used to pull a 5th wheel trailer! My uncle inherited it before I was born (I'm 22 btw) and drove it daily. Luckily my uncle took better care of it and even had it repainted. And it was still in excellent shape. Now when I started driving I started bothering him to sell it to me because I always liked the look of it. I'm not a big fan of trucks, or Jeeps, but Comanche's are different, you just don't see them every day.

 

Here she is the first day I owned it. At ~230xxx km and 95% rust free, 100% stock. This was April 2016.

FormatFactoryAAA.jpg.b8bf6530fe3d1fd1c462aaa58c1c0922.jpgFormatFactoryAAB.jpg.9d3aa904c87638f1e0bbc9157fbf5671.jpg

 

You can skip this paragraph. I got it in the mind of my uncle that I wanted it and he liked the idea of keeping it in the family, he offered it to me for $2500 but then gave it to my cousin's fiance free because she needed a vehicle. This c*nt beat the hell out of it, kept it dirty, and neglected it, I was not pleased. I bugged her every time I saw her that I wanted it. Well, after 3 years she decided to get a newer vehicle. So I offered her $500 for it! She accepted the offer! Glad she didn't know the value! 

 

The first thing I did was put on some 31" tires I found for $100. FormatFactoryAAC.jpg.0948764b06f40be0f1d6ceb61821d021.jpg

Not long after I had to stash the Comanche away. You see, I was living with my parents, I already owned 2 cars and they were not happy when I brought this home. We have limited parking space so I had to put it away for a few months. 

 

Stay tuned as the built really takes off from here.

FormatFactoryAAD.jpg

Link to post
Share on other sites

So here's what I don't like about Jeeps; they're damn slow. I don't know if my old renix 4.0 was super tired or if it was just mine but it was painfully slow! I like my sports cars and the low output of this thing was killing me. I couldn't get up to speed to merge, I couldn't pass on the highway at all, my top speed was 120km/h. I bet the 3.07 gears don't help.

 

So I went and found this:FormatFactoryAAE.jpg.b54a74b1fbcaca7932adb5f3853b5cd5.jpg

 

My plan was to collect parts until the 4L died, then, V8. I picked this up used, the guy said it had 500km on rebuild. Gen II small block Chevy 350, stock internals, edelbrock multi point EFI, ~300hp.

 

Now I said I lived with my parents, who have a tiny single car garage which I'm not allowed to use, so my older brother said it was alright to store the engine in his garage. After A few weeks he turned on me and asked when am I putting this motor in as it was in his way. Long story short I ended up paying him $50/month to use half his little 2 car garage. I was time to get this swap over with so I could get out of there.

FormatFactoryAAF.jpg.aa055f82a82575f6add8310b092025fa.jpgFormatFactoryAAG.jpg.f92bb72fdb7afb96cd475fa55f054862.jpg

The garage is small so I had to push the truck halfway out to have room for the hoist. The 4L still ran when I pulled it out which I regret. I ended up giving it away free to someone who made crafts out of it (pistons into lamps etc.). Just wish I did something fun with it.

FormatFactoryAAH.jpg.3ca9a51b90bc7de87d5b90344d802e19.jpg

I also did a lot of other stuff to the whole truck. I peeled the old, ripped, bed liner off, took the seats and carpet out, repaired the rust in the floor, cleaned, re-coloured, and re-installed the carpet, put in some new seats, removed the rear bumper with intentions to build a new one, and various other things I'm forgetting.

 

Here's the shinny engine bay with a fresh coat of black paint.

FormatFactoryAAI.jpg.02fb333b0187ac14b3b33a97a460e7a6.jpg

 

Link to post
Share on other sites

The truck started as a 4x4 so I kept it 4x4, which is easier said than done with an engine and trans that aren't supposed to be there. The transmission I used is a freshly rebuilt AX-15 5-speed from a wrangler and I kept the original NP231 transfer case but had it rebuilt. The motor mounts I bought from Novak conversions, I used an adapter bell-housing from Advance Adapters with a new Centerforce flywheel and clutch. The transmission didn't come with a shifter so splurged on a Hurst short shifter which cost me as much as the truck :crazy: Canadian dollar problems. Since the t-case was moved I had to get a cable shifter from Novak.

 

I  had a lot of issues with fitting the exhaust. The engine came with shorty headers so I figured I'd give em a shot; not even close!FormatFactoryAAA.jpg.9f07da68b6d66139e215b3319441cae0.jpgFormatFactoryAAB.jpg.43ab1f459c2479e02a807959b6a7ba9d.jpg

So i figures Novak also sells a set of headers for this swap that look like block huggers. Now I can't confirm if they are different or not but I bought some regular block huggers locally and they did not fit! They won't clear the steering shaft. Again, I really wish I had more pictures.  I ended up mounting the engine with no headers.

 

I was expecting to have to modify the hood but just fits! I got a drop-down air cleaner, the air cleaner and the alternator are about 1/4" from the hood! The accessory setup is the truck setup. Also keep in mind the oil pan to axle clearance. I put a 3" lift and added 2" of hockey puck bump stop in the front. I have yet to lift the rear though.

FormatFactoryAAC.jpg.07bcb8e5921982532ba196b8135ada35.jpg

I ordered some rams horn manifolds because they looked to be compact enough to fit and were fairly cheap. Guess what, they didn't fit! But they were so close! The flanges hit the frame!FormatFactoryAAD.jpg.a808d105f53df0b206f362d14b91dc80.jpg

I had to do some fabrication now. So here's what I did; I cut the flanges off and extended them with 2 1/2" square tubing, which meant welding cast iron, good thing my brother is a good welder!

FormatFactoryAAE.jpg.4cda7d9413fc5a53e3610937d1c63c37.jpg

Now they fit!

 

Feel free to request pics of certain things that are done.

Link to post
Share on other sites
4 minutes ago, MayhemManche said:

Well, to clarify, it's not a GM bellhousing. It's an Advance Adapters complete aluminum bellhousing not just an adapter.

Do you have any pics of the assembly? How is the slave mounted? What fork and TOB?

 

I've looked into the AA bell, can't find any good pics of it. 

 

Novak seemed to be the way to go.........but............I'd like to see what you got. 

Link to post
Share on other sites
32 minutes ago, Jeep Driver said:

Do you have any pics of the assembly? How is the slave mounted? What fork and TOB?

 

I've looked into the AA bell, can't find any good pics of it. 

 

Novak seemed to be the way to go.........but............I'd like to see what you got. 

ADD.png.d8129cf5b428ad4af485bc2c23a14950.png

Get the parts under optional items, you'd need all of them. Full description and instructions can be found here: http://www.advanceadapters.com/products/712567--chevy-v8--v6-to-jeep-wrangler-ax15-adapter-bellhousing-kit/

You can also order everything AA from summit racing, probably saves shipping.

 

I can take pictures when I have time.

Link to post
Share on other sites
On 2/12/2018 at 1:25 AM, Jeep Driver said:

Do you have any pics of the assembly? How is the slave mounted? What fork and TOB?

 

I've looked into the AA bell, can't find any good pics of it. 

 

Novak seemed to be the way to go.........but............I'd like to see what you got. 

Not really sure what you need to see but here.

 xg9fdejIwc7juma80mFv13w6FhFmZfTlASHVYtnVfSGyiDc-6y_-Gwsn69Vr6CDPf81rlVrpuUjOYVtmfR3odVwbxbuuINdcZR7WxPyG2NoOS9LdB-TckMPMSG3iczjNo2aAevaHhje88iqCl_PtkAHL5be4SRA578CNSzj-6Y7AztD9u5u4VmP7Kq3Bus2yV-mJhyxWcRrp5WSFfKfd0vABbEVtttO78UvrGiPpYAsZiVRNNb2vh1R5vdoVKRjChMa2eVs7rXcln7OR8gLeaRD456ehfFcR0bdrMcKeR3DrXrURG-tSunPrsPHKhcBAELRhR6v0itnRaLhgrgZtv_LopflF9GaAwLFFPxhMcUsB05P-jOrzeP6EUy7k6ZsrcvhbmcZ3LGLkkBjYWJOr2WbmIbvAcLZByYZRyRb04Pw70zhNX2MXld88Gae7vt7qnnjYwOVeP5p_D9kV9PzBXn-O-bPidGGvFOqTdfRsEB0f1vhTs407fihJvmy8OWVBaudZUBC7A-qJhfaY7d3l6dUPYp-xRSlBEp4PhnJFxXrfMkCX7NhRBOSNCOhQ1FlINki8X7xtsOoF5uvu9atdI4WP4aQ4x8XTxL4pUWM=w1760-h1320-no

Link to post
Share on other sites

So there's a big jump in progress in the next picture.

 FormatFactoryABA.jpg.81ff825f26bfcd30de81faa840351f60.jpg

The rear drive shaft went on although borderline too short, the amount of engagement on the slip yoke is a little sketchy. The front shaft was too long so it stayed off until I had it shortened. The plan is a Ford 8.8 rear and chromoly axles in the dana 30 front. But for the time being to reduce stress on the slip yoke and dana 35 I put the stock size tires back on.

 

I've pieced together the rad hoses, rad inlet and outlet are both on opposite sides of where they connect to the engine. I had a spacer made by a machinist for my rad cap/ water neck combo to put it high enough to air bleed the coolant. I have a Champion aluminum rad with 3 x 10" electric fans which does a good job at keeping the v8 cool enough.

FormatFactoryABB.jpg.f02a7add43db39a8c280b0409b7b276c.jpg

 

This is the point where I was regretting going EFI. It was a wiring headache but I figured I didn't want to have to maintain a carb. I had the harness and ECU from the chevy c1500 the engine came from. The engine was originally TBI but came with an Edelbrock multi-point EFI setup on it and a special chip in the ECU for it. The harness was a tangled mess that I ended cutting up and soldering back together. What a waste of time, I couldn't get a damn thing to work. :confused:

 

At this point I was frustrated and contemplating buying a carb but I came up with another, more expensive solution.:laugh: I was looking at aftermarket EFI when I came across the FAST EZ EFI 2.0 system and noticed I can order just the harness and ECU and try and use the TB and injectors I already had. Another $1500 dumped into the project! The touch screen dash and self tuning was a plus.

 

It was super easy to install. The only issue was that the injectors I had used a different connector, so I cut the connectors off my old harness and soldered them on and hoped it would work which it did!:beerbang:

FormatFactoryABC.jpg.9315e989c995a8014034c7c5ba22c1c6.jpg

She fired up and I had to see I move under its own power! I took it around the block, open headers screaming and shooting flames, at 10:30 pm, I bet the neighbors loved it :brows:.

 

Next was trailering it to an exhaust shop for 2.5" pipe off the manifolds then Y to a single 3" pipe with magnaflow muffler.

 

FormatFactoryABD.jpg.3acaeb7b50ad99ca4e47b07d851eb7f7.jpg

Now here's a fun story. Picking up my truck from the exhaust shop, guy who did it says one of the exhaust gaskets are leaking pretty bad, no big deal I'll drive it home and replace it. Ya I started it up and I could see flames though the gasket and it was loud. Anyway, I started driving it home and it was way down on power. I was thinking that it was because I had not yet installed the O2 sensor and therefore the ecu couldn't learn and was in limp mode. My house was close the shop so I continued. 2 blocks from my house I start to see orange in my rearview. THERE WERE 3 FOOT FLAMES COMING OUT MY TAILPIPE! Every time I let off the the gas, a constant steady flame until I accelerated! One block to go I didn't want to stop. Pretty much torching parked cars along the way. I got in front of my house and parked on the wrong side of the road, not risking turning around. Stupidly didn't check the temp gauge until I got there. 265 degrees. Shut off the engine and popped the hood. Checked the back of the truck wasn't on fire and opened the hood. My manifolds were WHITE HOT, not red, white! Notice my silicone spark plug wires with fiberglass heat shields? Ya, those were on fire! I was so scared I just nuked my engine in the first day. :sad:

 

Once it cooled off I installed the O2 sensor and fired it back up, gladly it did. Watched the temp gauge and within 2 minutes it was near 200 degrees. Experienced people probably know what it was and are thinking I'm an idiot. It was the ignition timing. It was so far off the combustion was happening when the exhaust valves opened. Turned the distributor and it ran fine. After that I did a compression test and it turned out great. Luckily I don't think I did any permanent damage, other than turning the chrome manifolds blue. :laugh:

 

A new exhaust gasket and spark plug wires were installed.

Link to post
Share on other sites

I had a few bugs to work out. First the throttle cable broke while merging onto the highway. Then another day the distributor rotor came loose, spun around, and broke the cap, on the highway. But other than that it runs pretty well.

 

In slow traffic I had a bit of a temperature issue. My water temperature was ok but if it was raining I could see steam come off the hood. And since I have that basic air cleaner the intake temps were high and caused a noticeable power drop. So I got a hood from the junkyard, saving my stock hood, and made some vents out of perforated steel and tech screws. It made a huge difference.

FormatFactoryABF.jpg.c9fe430cb485334f0cb6f6f957837f5e.jpg

Also put in some black projector headlights with LED's. I think it's a bit uglier this way but it'll look better later on.

Link to post
Share on other sites
17 hours ago, Jeep Driver said:

What accessory drive are you using? AC delete? do you plan on AC?

 

 

Probably too late now.........but you can successfully run duals out, X at the crossmember. 

Same as a 1994 c1500. Came with a compressor but I deleted it. Will probably stay that way. I prefer having the windows down.

 

Single just seemed easier and cheaper. 

Link to post
Share on other sites

Built a rear bumper with built in hitch from scratch. Pretty proud of it. It was a first for me and I never drew it out or anything. It's super solid, the main part of it is 3/16 wall 2x4" tube and the mounts are 1/4" steel attached to both the bottom and sides of the frame rails with grade 8 bolts.

FormatFactoryACA.jpg.c2c4ee3c975c07709c1c4dac3a2445cb.jpgFormatFactory20170803_135913.jpg.b5deb60e22a1951de29bc7d862b8d3bd.jpgFormatFactory20170803_135903.jpg.a5e3cf5e92a162e27f14aa801ab7aa08.jpgFormatFactory20170803_135853.jpg.31f60ab9dd5a89d07f3c148698777e8e.jpgFormatFactory20170803_135844.jpg.a9793ab8ca261aac2292954d8c23d77b.jpgFormatFactory20170803_135837.jpg.286cad65519dc823f7e85bcb6801f5f1.jpg

And yes, my tailgate is bent.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...