Jump to content

Recommended Posts

image.png.31f2cef492a6912ec78a5e135081c360.png

 

So this is the deal with the UCA's. Course they are the same for the XJ all years. It looks like the ZJ TJ and XJ have similar looking UCA's but probably don't interchange or probably were all the same at one point if I had to guess.

 

The LCA's are the same all years

Link to post
Share on other sites
  • Replies 158
  • Created
  • Last Reply

Top Posters In This Topic

1 minute ago, eaglescout526 said:

image.png.31f2cef492a6912ec78a5e135081c360.png

 

So this is the deal with the UCA's. Course they are the same for the XJ all years. It looks like the ZJ TJ and XJ have similar looking UCA's but probably don't interchange or probably were all the same at one point if I had to guess.

 

The LCA's are the same all years

Hmm interesting. Might have to order some mopar parts from you eventually for my

Zj and other mj :L:

Link to post
Share on other sites

Finishing up the steering today. 
-installed NEW upper Control arm yesterday and currently waiting for another to arrive for the drivers side upper. 
 

installed  tie rod ends and zj draglink with a new damper , and new shocks up front. 
75DCF06B-6BDC-43E4-B192-C2119B5618D1.jpeg.b5aeb626616dc1bb49a0c9eb250bacad.jpeg
841BADBA-FFB4-4390-9E6E-5DE83CA2989C.jpeg.fb570ba3e6009f342b83f432195465be.jpeg

 

89A6AA4D-280B-4924-A3A7-80A38E0F9DDE.jpeg.1d70e70cf644a7aa5eb3d07350ff8d45.jpeg

 

EB621754-E048-4383-B455-AAB499D89F39.jpeg.a36372d8da5bc2b5cbb859f55bdd086b.jpeg

 

62A58C5E-5F54-4822-AB28-A065BC96E9DA.jpeg.efe5485e390026a86608c8e8ce9a7768.jpeg

 

 

 

Link to post
Share on other sites
  • 2 weeks later...

Replaced the old

worn out Monroe’s on the rear. D3CBE05B-A124-46B6-8680-2A436C38031D.jpeg.b86e77d88f393ec34b3eaa275a6da7cf.jpeg
ACFE3301-FE90-4775-83DB-28F139EAF2D9.jpeg.652a778410d0d1c35d10e524f3472040.jpeg
422523DB-451F-45E6-9AF2-1AF2311FF24F.jpeg.d44b2494b4a11753da9417f50d5f30e0.jpegE7046D0E-0352-48F4-B3DE-4AF80E7BD937.jpeg.211e9325b96f765e95de112abe5f0526.jpeg
 

threw it on the alignment rack at work , got the toe dialed in but the caster is still off by a degree despite the new arms and bushings. Maybe I need to add a shim behind the lower

arm ? :confused:

21168C47-2E44-4399-9781-2BBC7255B5FF.jpeg.fdea84cac09c43cb3ae644d10939bb28.jpeg
 

still , this thing drives like it

never has before. Really happy with it. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...