Jump to content
Sign in to follow this  
STERLING STINGER

Rough Idle , Shifting wierd shot a vid

Recommended Posts

ive recently been noticing a rough idle in my 92.

it will idle perfect for a couple mins, but then it seems like it wants to stall out...it will either stall or almost stall on me.

It seems to do this even when i am in higher rpms on the roads....it sort of "bucks"

 

also, its shifting all crazy...itll downshift or won't upshift when its supposed to.

 

ive changed the map, plugs, wires, distributor cap n rotor, adjusted the tranny kickdown

 

no clue what else to try. I'm going to change the fuel filter today and check the ground behind the drivers side tail light.

 

hers the vid,,,its only doing it a little here ...it does it way worse than this

 

 

Any help or comments will be appreciated.

Share this post


Link to post
Share on other sites

Possible CPS going out. See what fault codes you have.

I have damn near this same idle on my 91, and there are times i go to take off and it just loses all spark for a millisecond then kicks back in. SO short a duration.

My rear main is going and i think there is oil all over everything in the bell housing. Didnt do it when i got it, now that rear main is pissin... its doing it a lot.

I'm gonna be doing rear main soon and cleaning everything real good.

Ill then report if my hunty idle and skipping running goes away.

cool you posted this cause makes me feel better. Mine is doing EXACT same thing. that idle with pieces missing... lol.

Share this post


Link to post
Share on other sites
Possible CPS going out. See what fault codes you have.

I have damn near this same idle on my 91, and there are times i go to take off and it just loses all spark for a millisecond then kicks back in. SO short a duration.

My rear main is going and i think there is oil all over everything in the bell housing. Didnt do it when i got it, now that rear main is pissin... its doing it a lot.

I'm gonna be doing rear main soon and cleaning everything real good.

Ill then report if my hunty idle and skipping running goes away.

cool you posted this cause makes me feel better. Mine is doing EXACT same thing. that idle with pieces missing... lol.

 

Let me know when you go after the RM, I'll let ya do mine too. :yes:

Share this post


Link to post
Share on other sites

:eek:

 

NICE! so now that helps my brain. if mine keeps it up after rear main and clean CPS, I'm gonna clean my throttle body and then maybe ill need a TPS too.

We shall see... :wrench:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...