Jump to content

Not getting fuel...cranks but won't start


Recommended Posts

Ok here is my problem: 1989 straight six fuel inj, runs great after it starts. For now, just grinds away. In the last 30 days have replaced the Fuel pump, Fuel filter, Fuel Pump Relay, battery cables, serpentine belt, plugs, removed and cleaned gas tank...all by pro mechanic at his shop.

 

Just had the fuel repair work done week b4 last and all was well. Truck sat for 5 days, and it started and ran yesterday for 2 minutes or so just to test it. Then today, will not start....just cranks. No fuel at the fuel pressure valve spurts out.

 

New fuel pump has been removed and tested externally as excellent.

 

Any ideas?

Link to comment
Share on other sites

it's located at about 11:00 on the bellhousing. Look for a large squarish weatherpack connector toward the driverside rear of the engine at the firewall. Unplug and replug and see if it starts. If yes, replace the sensor.

 

Also, check the fuel pump ground for intermittent contact. It's behind the driverside taillight assembly. Clean/tighten as necessary.

 

Jeff

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...