Jump to content
BLHTAZ

Electrical Manual

Recommended Posts

This looks like the one I PDFed. image_209027.gif How do you link it?
I host it on my personal website. That's why I ask that folks save it to their computer insted of running it off of my site so it doesn't use up all my bandwidth. ;) I have 300mb of space to use and right now I am using about 237mb of it...

 

It probably did come from you. I know that I got it from someone on here quite a while back, but couldn't remember who to give credit to...so here's to you for doing that :cheers: :bowdown: jamminz.gif

Share this post


Link to post
Share on other sites

Ah, it got all the way to the 'download' part. It's no biggie - I have some downtime at work and was going to read through it to figure out some electrical issues I have.

Share this post


Link to post
Share on other sites

Thank you so much for this book! I have owned multipul comanches but have never been able to get my hands on one of these! I can now fix my comanche in my old forgetful age... when i get my doner jeep... and when warm weather comes about... and when i get my arm out of a cast... :rotf:

Share this post


Link to post
Share on other sites

Thanks C.A. I just downloaded and saved. I am sure I will be able to trace the problem.

 

Wow...just joined last week when I bought the truck and already I am benefiting.... :thumbsup:

Share this post


Link to post
Share on other sites

What a great resource. Went to get inspected today and it failed becuse when the headlights are on the right turn signal quits working, and sometimes the backup lights blink. The back side of the headlamp switch got hot and melted at some point, so perhaps some damage to the wires was done. Going to have to take the dash aprt, but first I might just replace the multi function switch inside the column to see if that fixes it.

Share this post


Link to post
Share on other sites

Thanks for the manual. I just bought my MJ today and the dash lights don't come on nor do the rear tail "running lights" but the turns work.

Hope to figure this out soon. Never had an issue like this on my XJ's but always owned 98-01's.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×