Jump to content

ohiostate454

Members
  • Content Count

    76
  • Joined

  • Last visited

Everything posted by ohiostate454

  1. So I thought I would throw this here to hopefully get some quick help. Repulled my dash on my Cherokee to look at the vacuum system and missed one line. Would that one line cause the whole system to fail?
  2. So one line was unplugged when I got the dash out. Would that one like not being hooked up cause the whole system to fail?
  3. It's supposed to be a feels of temp of 120ish here tomorrow so I'm pulling it in the attached garage with an ac unit and taking a stab at it.
  4. I haven't checked the actuators but I don't have a clicking noise I did check for a cracked canister and still nothing there. I unhooked and plugged the line to check it
  5. It's there for sure so I think its between that connection and the switch connection. I am more then likely going to have to pull the dash again its looking like.
  6. So not directly on a comanche but on my 99 Cherokee after it has gotten hot and you shut it off and start to go again. The first time it tries to go from 1st to 2nd it really surges and sputters and almost stalls. It only does it one time then it is fine. Untill the next time you shut it down and restart it. I know a lot of people have done swaps to modern 4 liters so any help would be great. It has new plugs, wires, cap, my thought was throttle body sensor, or maybe the MAP but since it will literally only do it once per cycle I have no idea.
  7. Well made some more progress on the jeep and have been driving it to work still have some weird problems that I could use some help with. When you first start it after it is warm it seems to have a very in the idle and the first time it goes to shift from 1st to 2nd it has a surge that will cause it to chug. I am thinking it may possibly be the throttle position sensor but was curious what anyone else thinks? I also still do not have use of the blower doors to change the position. I tracked through the engine and don't have any vacuum leaks so I'm wondering if it is something in the heater core? I am really stumped on that and would like to be able to direct the ac again so it isnt stuck on defrost lol.
  8. It's a 99 little rough around the edges but the local JY is having a 50% off sale this weekend so that should help me solve some of the body damage problems.
  9. Well I finally had time to pick her up from my parents house and drove it 170ish miles home. Ran like a top at 75 the whole way home. I for sure have a vacuum leak since its stuck on defrost only the cruise won't work either. Also might have a slight coolant leak I need to track down as well. First order of business is the vacuum leak and then get the rear hatch to open.
  10. She is all in for it.............although idk if she knows of all the plans in store for it lol. First is do basic maintenance and let my younger brother drive it to his senior year of high school for a couple weeks before I make the 120 mile trip home with it. 3" lift, 31s, 17" moab wrangler wheels, JCR bumpers, I will probably fab some rock sliders and cut out the rusty rockers. Plus a few HP mods along the way. My dad worked for Roush for years so if the motor goes ever it might be due for a crazy swap to match his 71' 440 dart.
  11. So I have wanted a Comanche for years now and I after getting married, getting a house, etc we finally got to a point that we had some money to buy one. However since my dream of getting a Comanche I got a wife and two dogs so that doesnt really work for a single cab truck as a camping/light wheeling rig. So I found this beaut. 500 Bucks guy bought it parked it in the back yard and went to replace the heater core and it wouldnt crank and no spark. So we drove through a snow storm to go look at it get there it isnt in awful shape for 500 bucks. I had assumed the NSS was the problem but wasnt sure. Talked with the guy he hands me the keys I hop in wiggle it in neutral and it rolls over and starts and ran beautifully. Thankfully the guy stuck by his word and still sold it to me for 500 bucks and I drove it on the dolly pulled the rear drive shaft and away we went. So its currently sitting at my parents house since it was close to them and my dad has a car lift in the barn seems like a good place to start. More to come in a few weeks when the boxes of parts get delivered and I have time to go back. So $500 running driving 150k mile loaded XJ project is a go.
  12. http://imgur.com/8yUPrmh
  13. Ya I will snap a few before I leave for work.
  14. ohiostate454

    Roof racks

    Hey so me and my wife just went and bought kayaks and a roof rack system for her 2012 Liberty. I do not have any experience with roof racks as I also have my truck. When I started to install them I noticed that these specfic ones did not over hang off the side of the brackets and sat inside forcing me to take the endcaps off. Has anyone had an experience with this? The rack is a 50 inch malone universal rack I am debating seeing if I can get the 58 inch rack so it sticks through the brackets and over the edge of the side mounting rail. I hope this makes sense as we are leaving on a 4 hour trip tomorrow that is also half highway so I don't want to lose 2 brand new kayaks doing 70 down the highway. Or I could just be overthinking things. Any help would be great thanks.
  15. Ok so my wife is about to graduate from her masters program and I just bought a WRX for my self and now it is time for an upgrade for her. We looked at a 2012 Liberty Latitude edition with about 54,000 miles on it for almost 17,000. I am wondering if anyone here has one and if they have had any problems with them? I looked online and everyone seems to think they are slow and tightly cramped inside I am 6 foot 200lbs and I didnt think it was that bad other then a little loud on the inside. Also if anyone has one what kind of MPG are you getting with it she will be driving a lot and lots of freeway driving and country roads. Any input would be great thank you.
  16. Hey I haven't been on the site in a while and I got back on recently for some bumper ideas for my buddies rig.I am having issues with none of the pictures showing up in the threads I was wondering if this was just me or if something happened?
  17. Went home to my parents house this weekend to get married. The day before I got home tornado went through the yard took all the trees down and dropped a tree on my 99z71 I had just put insurance on to drive home. :doh: I mean still got married and it was great couldn't have been better wedding went well. Got home today and some idiot decided to rip the wiper bars off my car, and the lift for my truck came in the mail lol. So I just wanted to complain because it was quite the good but frustrating weekend.
  18. I didnt notice any visible bondo but like I said I didnt really have time to look it over real well. As for the stickers they seemed to be the same there was a little rust on the drivers rocker and it had a grey bench with and idiot light gauge pack. The next time I go back I will look them over better and take a few more pictures.
  19. There was a fourth one there but I didnt have time to get a pictures of them and I am not sure of the years or anything. This is my stepdads college roommate's yard and there are tons of amcs and whatnot. As for the gray one no rust couldn't get the hood to see the motor or anything it is in great shape I use that term loosely :brows:. I am hoping to buy it in the summer from them. But it is in Midland so if you need parts or info get ahold of me its a great yard tons of old stuff very helpful and they would love some business as they have been forced to scrap a lot of the cool older cars.
  20. So does anyone else have problems viewing pictures in threads on google chrome? Half the time it loads half the time they don't.
  21. I hear a lot of people have problems with it if I had the time I would rebuild it with the beast sunshell a clutch kit and transpack but I don't have that time. My friends camaro did the same thing last summer but the truck is getting old and I am hard on all 330 horse it has lol. One day it will be rebuilt right and a tow rig to a Comanche.
  22. Was pulling out of the bank Monday and the 4L60E decided it no longer wanted to be a working part of the drive train.So no I have to drive my mom to work and use her car till I can get a replacement trans. Really just needed to vent. If i had another car I would just replace the Sun shell which blew up with an upgraded one but since its my only transportation and I need to get to work, the JY replacement will have to due for now. :fs1:
  23. I might just have to do that I agree with the A**TEK and gms no soild front axles. Had a fiero with the 2.8 though and didnt mind it. hopefully I can just find a Comanche and only drive my silverado in the winter
  24. Right now I am trying out those E3 plugs they are about a year old. The programmer is on the list I just am working on saving up the money driving 36 miles to school one way 4 days a week and working at subway doesnt leave a whole lot of room for money saving lol. I thought about the higher octane gas but I just spent 90 bucks in unleaded to fill up I ran the higher octane once when it was cheaper and didnt notice much of an improvment. I was going to run injector cleaner and maybe some oil additive but I didnt know what was the good stuff was and what the stuff that will hurt it in the long run was.
  25. ohiostate454

    Gm Problems

    I know everyone here hates GM but I just happen to have a 99 silverado and i have been working on it since I got it from my grandpa a few months ago. I have done some body work and done some slight performance upgrades plugs throttle body spacer cold air intake. Which leads me to my problem. Shortly after putting the Specter cold air kit on I noticed when it is cold out that I get some spark knock, the computer was suppose to adjust its self to make the new system work (according to GM). I want to put dual thrush's on it my buddy gave me but I also don't want to make the knock worse. anybody got any ideas on what to do? I asked on a silverado forum but they all act like your an idoit and offer no help cause all other forums suck. Hopefully one day I will actually have a Manche to call my own and ask some Comanche specific questions :thumbsup: :MJ 1: . Any help would be great tho thanks
×
×
  • Create New...